Bug 187592 - nautilus takes too much CPU when copying files
nautilus takes too much CPU when copying files
Status: CLOSED DUPLICATE of bug 215890
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-01 08:28 EST by Vladimir Kotal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 03:26:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Kotal 2006-04-01 08:28:10 EST
Description of problem:

nautilus takes too much CPU during files copying

Version-Release number of selected component (if applicable):

nautilus-2.14.0-1

How reproducible:

copy large directory with number of files (e.g. mp3 collection) to another disk and run top(1)

Steps to Reproduce:
1. copy directory with big number of files in nautilus
  
Actual results:

nautilus takes cca 30% CPU time when copying large directory:

top - 15:28:19 up  5:15,  2 users,  load average: 4.63, 2.59, 1.37
Tasks: 113 total,   2 running, 111 sleeping,   0 stopped,   0 zombie
Cpu(s): 12.6% us, 35.2% sy,  0.0% ni,  0.0% id, 52.2% wa,  0.0% hi,  0.0% si
Mem:   1816204k total,  1772596k used,    43608k free,    10944k buffers
Swap:  1048568k total,      252k used,  1048316k free,  1347548k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
 3002 katka     15   0  121m  41m  21m S 37.2  2.3   4:41.07 nautilus           
 2865 root      15   0  267m 122m 9088 S  3.3  6.9   6:18.89 Xorg               
 4801 root      10  -5     0    0    0 D  1.7  0.0   0:07.79 usb-storage        
  158 root      15   0     0    0    0 S  1.0  0.0   0:07.05 kswapd0            
 6102 root      15   0     0    0    0 S  1.0  0.0   0:00.32 pdflush            
 6108 root      15   0     0    0    0 D  1.0  0.0   0:00.18 pdflush            
 6107 root      15   0     0    0    0 D  0.7  0.0   0:00.14 pdflush            
    2 root      34  19     0    0    0 R  0.3  0.0   0:03.83 ksoftirqd/0        
 2414 haldaemo  17   0  5268 3572 1764 S  0.3  0.2   0:06.64 hald               
 3056 katka     15   0 70052  12m 9852 S  0.3  0.7   0:03.71 stickynotes_app    
 3180 katka     15   0 55904 8004 5604 S  0.3  0.4   0:05.95 xmms               
    1 root      16   0  1988  672  580 S  0.0  0.0   0:00.94 init               
    3 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 watchdog/0         
    4 root      10  -5     0    0    0 S  0.0  0.0   0:00.01 events/0           
    5 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 khelper            
    6 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kthread            
    8 root      10  -5     0    0    0 S  0.0  0.0   0:00.10 kblockd/0          

Expected results:

nautilus should not exhaust CPU that much - it is just displaying progress, 
not doing any real work

Additional info:
Comment 1 Alexander Larsson 2006-09-04 12:22:44 EDT
This might be better in fc6, I made some changes related to this
Comment 2 Luis Cruz 2006-11-20 13:21:53 EST
I am running FC6, and I am getting 100% CPU usage when copying from a windows
share in the same network segment (didn't test with other configurations). I am
running FC6 with kernel 2.6.18-1.2798.fc6-i686 and nautilus-2.16.2-5.fc6. The
computer is a Toshiba Tecra M1 laptop.
Comment 3 Alexander Larsson 2006-11-21 03:26:54 EST

*** This bug has been marked as a duplicate of 215890 ***

Note You need to log in before you can comment on or make changes to this bug.