This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 187615 - install fails with exception
install fails with exception
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-01 15:16 EST by Andre Robatino
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 09:44:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anacdump.txt (62.13 KB, text/plain)
2006-04-01 15:16 EST, Andre Robatino
no flags Details
anacdump.txt for graphical install with 256M (74.50 KB, text/plain)
2006-04-01 19:18 EST, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2006-04-01 15:16:22 EST
Description of problem:
  I was helping my father try to do a clean install of FC5 on a dual boot
FC3/Win98 box with 128M.  It said that due to low memory, it had to do a text
install.  During the text install, it said something about having to immediately
swap something to the hard drive, or something like that, which we OK'ed. 
Finally the install started.  About 1/3 of the way through, it failed with an
exception.  We chose the "Save" option to save the output to a floppy, attached
here.

Version-Release number of selected component (if applicable):
anaconda-11.0.5-1

How reproducible:
don't know (probably always on this hardware)
Comment 1 Andre Robatino 2006-04-01 15:16:22 EST
Created attachment 127184 [details]
anacdump.txt
Comment 2 Andre Robatino 2006-04-01 19:18:23 EST
Created attachment 127190 [details]
anacdump.txt for graphical install with 256M
Comment 3 Andre Robatino 2006-04-01 19:20:01 EST
  We temporarily increased the machine's memory to 256M and tried a graphical
install, but with essentially the same result.  Attachment above.
Comment 4 Andre Robatino 2006-04-01 22:05:59 EST
  Should have mentioned above - the attempted installs were from CDs.  All 5 CDs
tested good with mediacheck, and the machine is known from past experience to
not be vulnerable to the mediacheck bug (bug #186512).  There was 8 GB available
on the HD.  I did a successful install on a very similar machine with more
packages included and only 6 GB available, so HD space should not be an issue.
Comment 5 Andre Robatino 2006-04-02 18:02:30 EDT
  Reassigning to high severity since installation is impossible and there
appears to be no workaround (other than another installation method, which due
to being on dialup is impractical).
Comment 6 David Cantrell 2006-04-03 09:44:17 EDT
Looks like you have a bad CD-ROM drive.  In the dump file, I see this:

<4>hdc: command error: status=0x51 { DriveReady SeekComplete Error }
<4>hdc: command error: error=0x50 { LastFailedSense=0x05 }
<4>ide: failed opcode was: unknown
<4>end_request: I/O error, dev hdc, sector 678584
<3>Buffer I/O error on device hdc, logical block 169646

Which indicates a hardware failure (either the drive itself, the cable, etc).
Comment 7 Andre Robatino 2006-04-04 16:58:21 EDT
  We tried switching the CD drive with an identical model, and got the same
error in 2 or 3 attempts to install FC5, even though CD access seemed faster. 
Then we successfully installed FC4 on the first try.  So even if it is a
hardware issue, it must selectively affect the FC5 installer somehow.  Is there
NO way this could be an OS bug masquerading as a hardware problem?

Note You need to log in before you can comment on or make changes to this bug.