Bug 187624 - selinux-policy-targeted denies java_vm libdeploy.so
selinux-policy-targeted denies java_vm libdeploy.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-01 18:45 EST by John Griffiths
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 11:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2006-04-01 18:45:00 EST
Description of problem:
libdeploy.so of jdk1.5.0_06/jre is denied execmod

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install java plugin in firefox
2. Load a page that runs a java aplet.
3.
  
Actual results:

Apr  1 16:25:31 gei kernel: audit(1143926724.607:7204): avc:  denied  { execmod
} for  pid=11628 comm="java_vm" name="libdeploy.so" dev=dm-0 ino=716039
scontext=user_u:system_r:unconfined_t:s0 tcontext=system_u:object_r:lib_t:s0
tclass=file


Expected results:
No AVC message

Additional info:
Work around is
    chcon -t textrel_shlib_t /opt/jdk1.5.0_06/jre/lib/i386/libdeploy.so
Comment 1 Daniel Walsh 2006-04-03 11:49:33 EDT
Fixed in selinux-policy-2.2.29-2.fc5
Comment 2 John Griffiths 2006-04-10 09:06:45 EDT
This seems to be fixed in selinux-policy.noarch 0:2.2.29-4
Comment 4 Daniel Walsh 2006-05-05 11:01:12 EDT
Closing as these have been marked as modified, for a while.  Feel free to reopen
if not fixed

Note You need to log in before you can comment on or make changes to this bug.