Bug 187642 - freeglut 2.4.0 aborts with "Failed to create cursor"
Summary: freeglut 2.4.0 aborts with "Failed to create cursor"
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: freeglut   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-02 05:41 UTC by Walter Neumann
Modified: 2018-04-11 11:03 UTC (History)
2 users (show)

Fixed In Version: 2.4.0-11.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 22:17:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Walter Neumann 2006-04-02 05:41:42 UTC
Description of problem:Running knotplot, which depends on freeglut, the program
aborts with a message 
"freeglut (knotplot): Failed to create cursor"

Version-Release number of selected component (if applicable):
freeglut-2.4.0-4

How reproducible:
Try to run knotplot. This is a known bug that affects other programs too, see
http://sourceforge.net/mailarchive/forum.php?thread_id=8199462&forum_id=6252


Steps to Reproduce:
1. run knotplot
2.
3.
  
Actual results:
Program aborts with message 
"freeglut (knotplot): Failed to create cursor"

Expected results:
program runs.

 

Additional info: Downgrading freeglut to 2.2.0 fixes the problem. But a patch
for freeglut 2.4.0 has been posted at the above link, which I have not tried

Comment 1 Mike A. Harris 2006-04-04 01:35:45 UTC
Please report this issue to the freeglut project's bug tracker on sourceforge,
and/or discuss the issue on one of the freeglut mailing lists.  Once the
developers have officially blessed a particular patch/solution and committed
it to CVS, we will review it and consider it for inclusion in a future
update.

Please provide a URL to the upstream bug report for tracking purposes.

Thanks in advance.

Comment 2 Walter Neumann 2006-04-04 02:33:38 UTC
It has apparantly been fixed in CVS for over 8 months but the last stable
release, which seems to be the fedora version, was 9 months ago.

https://test.sf.net/mailarchive/forum.php?thread_id=8208707&forum_id=6251

Comment 3 Mike A. Harris 2006-04-04 13:30:49 UTC
Ugh.  I must praise the freeglut project for having decent enough ideology
to free the GLUT API from the non-open license the original GLUT implementation
was under, but unfortunately they lose points for not embracing the open
source concept of "release early, release often".  In 3 years (or is it 4?)
they have released 2 versions of freeglut, and never ever release bugfix
releases ever.

Perhaps it is time for us to consider looking into OpenGLUT as an open
source alternative to freeglut.



Comment 4 Mike A. Harris 2006-06-06 01:21:12 UTC
(In reply to comment #3)

> Perhaps it is time for us to consider looking into OpenGLUT as an open
> source alternative to freeglut.

A month or so ago I investigated OpenGLUT, and it turns out to not be
a suitable replacement, as it does not guarantee compatibility with
GLUT like freeglut does.

So, we're stuck using freeglut and patching it for the time being...



Comment 5 Matěj Cepl 2007-04-04 22:05:47 UTC
Reporter, could you confirm please, that this bug still could be reproduced with
the latest release of Fedora (FC6)?


Comment 6 Walter Neumann 2007-04-24 20:44:08 UTC
Yes it is still the same bug both in FC6 with freeglut-2.4.0-11.fc6 and in FC5
with freeglut-2.4.0-4

Comment 8 Adam Jackson 2007-07-27 21:50:44 UTC
This isn't my bug.

Comment 9 Hans de Goede 2007-07-27 22:17:07 UTC
This has long been fixed:

* Sun Mar 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.4.0-11
- Minor specfile cleanups
- Add a patch from gentoo to stop flightgear from crashing

That patch from gentoo is the same patch as linked to above, and
freeglut-2.4.0-11.fc6 has been available from Fedora Extras since March 19 2007,
closing.





Note You need to log in before you can comment on or make changes to this bug.