Bug 1876515 - Pipeline with taskSpec breaks UI
Summary: Pipeline with taskSpec breaks UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Karthik Jeeyar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1879247
TreeView+ depends on / blocked
 
Reported: 2020-09-07 11:37 UTC by Karthik Jeeyar
Modified: 2021-01-18 16:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1915013 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:38:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pipeline with taskSpec does not breaks UI (83.46 KB, image/png)
2020-09-20 21:33 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6541 0 None closed Bug 1876515: Fix inline taskSpec error in pipeline page 2021-02-11 21:52:34 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:38:38 UTC

Description Karthik Jeeyar 2020-09-07 11:37:37 UTC
Description of problem:
When user creates a Tekton pipeline with taskSpec and tries to open it in Pipelines page, the page shows "Oh no! Something went wrong."



Version-Release number of selected component (if applicable):

Pipelines operator 1.0 or 1.1 on OCP 4.5 or 4.6

How reproducible:
Always


Steps to Reproduce:
1.click Import Yaml  in top-right corner
2.paste the following code there

###
apiVersion: tekton.dev/v1beta1
kind: Pipeline
metadata:
  name: devconsole
spec:
  tasks:
  - name: use-secret
    taskSpec:
      steps:
      - name: greet
        image: registry.access.redhat.com/ubi8/ubi
        script: |
          #!/usr/bin/env bash
          echo "Hello world!"
 ###

Actual results:
Page shows an error with description "t.taskRef is undefined"

Expected results:
Page with pipeline details is displayed

Comment 2 spathak@redhat.com 2020-09-20 21:33:12 UTC
Created attachment 1715474 [details]
Pipeline with taskSpec does not breaks UI

Comment 3 spathak@redhat.com 2020-09-20 21:34:13 UTC
Verify on build version: 4.6.0-0.ci-2020-09-19-115132
Browser version: Chrome 84

Comment 6 errata-xmlrpc 2020-10-27 16:38:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.