Bug 187655 - system-config-lvm aborts on startup
system-config-lvm aborts on startup
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-04-02 07:18 EDT by Émeric Maschino
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-12 17:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Parted changed format of output - fix (3.48 KB, text/plain)
2006-05-12 12:18 EDT, Stanko Kupcevic
no flags Details

  None (edit)
Description Émeric Maschino 2006-04-02 07:18:05 EDT
Description of problem:

Invoking system-config-lvm gives produces the following output in the console:

Traceback (most recent call last):
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 138, in ?
    runFullGUI()
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 123, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 68, in __init__
   self.lvmm = lvm_model()
  File "/usr/share/system-config-lvm/lvm_model.py", line 142, in __init__
    self.__block_device_model = BlockDeviceModel()
  File "/usr/share/system-config-lvm/BlockDeviceModel.py", line 19, in __init__
    bd = BlockDevice(devname)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 41, in __init__
    self.reload()
  File "/usr/share/system-config-lvm/BlockDevice.py", line 68, in reload
    self.__parted_reload()
  File "/usr/share/system-config-lvm/BlockDevice.py", line 84, in __parted_reload
    self.addNoAlign(part.beg, part.end, part.id, part.bootable, part.num)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 213, in addNoAlign
    self.__insert(part)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 218, in __insert
    self.__insert2(part, self.__segs, False)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 248, in __insert2
    raise BlockDeviceErr_cannotFit()
BlockDevice.BlockDeviceErr_cannotFit: <BlockDevice.BlockDeviceErr_cannotFit
instance at 0x2000000006e360e0>


Version-Release number of selected component (if applicable):

system-config-lvm 1.0.13-1.0

How reproducible:

Always

Steps to Reproduce:
1. Invoke system-config-lvm (CLI or GUI)
2.
3.
  
Actual results:

The system-config-lvm window pops up for a few milliseconds and then closes with
the above messages in the console (when invoked using CLI)

Expected results:

The system-config-lvm window shouldn't close

Additional info:

This bug seems closely related to bug #169860. I'm opening this one because the
platform is different (ia64) and because bug #169860 seems to have been solved,
which isn't the case here
Comment 1 Stanko Kupcevic 2006-05-11 17:29:38 EDT
Could you post the output of 'sfdisk -l -uS <devname>' for all hard drives.
Comment 2 Émeric Maschino 2006-05-12 02:33:10 EDT
Unfortunately, sfdisk doesn't support GPT partitions, the standard on Itanium
systems (see below the sfdisk output for disk /dev/sda). Is there something else
I can try?

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util sfdisk
doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 8924 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sda1             1 143374737  143374737  ee  EFI GPT
                start: (c,h,s) expected (0,0,2) found (0,0,1)
/dev/sda2             0         -          0   0  Empty
/dev/sda3             0         -          0   0  Empty
/dev/sda4             0         -          0   0  Empty
Comment 3 Stanko Kupcevic 2006-05-12 12:18:12 EDT
Created attachment 128947 [details]
Parted changed format of output - fix

Well, you could test a fix. 

Just drop the attachment into /usr/share/system-config-lvm/ , and it should fix
the problem.
Comment 4 Émeric Maschino 2006-05-12 17:08:39 EDT
Wow, impressive! I confirm that attachment id #128947 solves the problem. Many
thanks.
Comment 5 Stanko Kupcevic 2006-05-12 17:25:05 EDT
Fixed in 1.0.17

Thanks for beta-testing :)

Note You need to log in before you can comment on or make changes to this bug.