Bug 187660 - scim does not work with x86_64
scim does not work with x86_64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 07:59 EDT by Giuseppe Castagna
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 14:27:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giuseppe Castagna 2006-04-02 07:59:41 EDT
Description of problem:

Installed and launched scim, scim-anthy, scim-i17n. When launched the gnome icon
appears by right clicking has no effect, nor has ctr-space, and the toolbar does
not appear.

 
Version-Release number of selected component (if applicable):

scim-1.4.4-9.1.fc5
scim-m17n-0.2.0-2
scim-libs-1.4.4-9.1.fc5
scim-anthy-1.0.0-1.fc5
scim-libs-1.4.4-9.1.fc5
Linux lampone 2.6.16-1.2080_FC5 #1 SMP Tue Mar 28 03:38:47 EST 2006 x86_64
x86_64 x86_64 GNU/Linux


How reprducible:

When I launch scim under gnome the icon appears in the icon tray but clicking it
does not give me the list of input modes and ctr+space has no effect (note that
it worked perfectly with FC5t2 and FC5t3, but stopped working after my fresh
install of FC5).

I removed the current version and yum reinstalled all:

$ sudo rpm -e scim-libs scim scim-m17n scim-anthy
$ sudo yum install scim-libs scim scim-m17n scim-anthy


=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 scim                    x86_64     1.4.4-9.1.fc5    updates-released  270 k
 scim-anthy              x86_64     1.0.0-1.fc5      updates-released  389 k
 scim-libs               x86_64     1.4.4-9.1.fc5    updates-released  751 k
 scim-libs               i386       1.4.4-9.1.fc5    updates-released  756 k
 scim-m17n               x86_64     0.2.0-2          core               48 k
Installing for dependencies:
 libstdc++so7            i386       4.2.0-0.3.20060203.2  core              309 k
=============================================================================


I rebooted, tried to launch scim from a fresh account. But same problem, the
icon appears and no input mode menus. No tool bar, no effect with ctr+space.
Comment 1 Jens Petersen 2006-04-02 20:32:25 EDT
I believe you tried gtk2 apps, how about KDE (eg kedit) and X apps (eg xterm)?
Comment 2 Jens Petersen 2006-04-02 20:34:21 EDT
And what is the output of "printenv | grep -i scim"?
Comment 3 Jens Petersen 2006-04-03 05:48:54 EDT
Also any errors in install.log?
Comment 4 Giuseppe Castagna 2006-04-03 13:38:45 EDT
> I believe you tried gtk2 apps, how about KDE (eg kedit) and X apps (eg xterm)?

tried with xterm ... no change (I've not kde installed)

> And what is the output of "printenv | grep -i scim"?

nothing at all (and scim daemon is running)

> Also any errors in install.log?

Apparently none:

[root@lampone ~]# grep -i error install.log
Installing libgpg-error-1.1-1.2.1.x86_64.
Installing libgpg-error-1.1-1.2.1.i386.
Installing libgpg-error-devel-1.1-1.2.1.x86_64.
[root@lampone ~]# grep -i scim install.log
Installing scim-libs-1.4.4-9.x86_64.
Installing scim-1.4.4-9.x86_64.
Installing scim-anthy-0.9.0-2.fc5.1.x86_64.

I am very ready to install scim from scratch and test it on a fresh account
(indeed this is what I did before, so may you'd better send me precise
instructions). However notice that scim worked till fc5t3 with the very same
account I'm using now (I did a fresh install of FC5 but kept my several years
old home partition)
Comment 5 Jens Petersen 2006-04-03 20:05:10 EDT
> > And what is the output of "printenv | grep -i scim"?
> 
> nothing at all (and scim daemon is running)

Ah, so does running

  GTK_IM_MODULE=scim gedit

work? :)

What locale are you running in?  fr_FR.UTF-8?

You probably want to make a symlink like:

  ln -s /etc/X11/xinit/xinput.d/scim ~/.xinput.d/fr_FR

or replace "fr_FR" with "default" if you want to use scim in your account
for any locale.

I originally assumed you already had this since you said you already had scim
working in fc5 test releases.
Comment 6 Giuseppe Castagna 2006-04-05 14:27:12 EDT
Gee, me stupid. I am so ashamed: when I did fresh install of FC5 I took the
occasion to remove some config files, some of which where several year old and
unused. Guess what? I removed ~/.xinput.d. 
  I really apologize for the time you lost on such a stupid mistake of mine. Sorry
and thanks ... "bug" closed.

Note You need to log in before you can comment on or make changes to this bug.