Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1876695

Summary: Fail to scale up RHEL worker due to missing openvswitch package dependency.
Product: OpenShift Container Platform Reporter: Johnny Liu <jialiu>
Component: DocumentationAssignee: Kathryn Alexander <kalexand>
Status: CLOSED CURRENTRELEASE QA Contact: Johnny Liu <jialiu>
Severity: high Docs Contact: Vikram Goyal <vigoyal>
Priority: high    
Version: 4.6CC: adahiya, aos-bugs, dcbw, jokerman, kalexand, yanyang
Target Milestone: ---Keywords: Regression
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-10 19:24:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1874324    
Bug Blocks:    

Description Johnny Liu 2020-09-08 01:32:14 UTC
Description of problem:
Fail to install openvswitch2.13 package during RHEL scaleup process in 4.6 due to missing dependency packages - openvswitch-selinux-extra-policy.


Version-Release number of the following components:
openshift-ansible-4.6.0-202009042223.p0.git.0.3c6d337.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Scale up RHEL worker against a 4.6 cluster
2.
3.

Actual results:
Failed as the following:
TASK [openshift_node : Install openshift support packages] *********************
Monday 07 September 2020  19:03:24 +0800 (0:00:00.222)       0:00:03.950 ****** 
FAILED - RETRYING: Install openshift support packages (3 retries left).
FAILED - RETRYING: Install openshift support packages (3 retries left).
FAILED - RETRYING: Install openshift support packages (2 retries left).
FAILED - RETRYING: Install openshift support packages (2 retries left).
FAILED - RETRYING: Install openshift support packages (1 retries left).
FAILED - RETRYING: Install openshift support packages (1 retries left).
<--snip-->
fatal: [10.0.1.7]: FAILED! => {"ansible_job_id": "770320612234.11328", "attempts": 3, "changed": true, "changes": {"installed": ["setools-console", "skopeo", "runc", "containernetworking-plugins", "cri-tools", "nfs-utils", "dnsmasq", "iscsi-initiator-utils", "device-mapper-multipath", "sssd", "tmux", "nmap-ncat", "openvswitch2.13", "iptables-services", "container-storage-setup", "ceph-common", "cifs-utils", "glusterfs-fuse"], "updated": [["kernel", "3.10.0-1127.19.1.el7.x86_64 from rhui-rhel-7-server-rhui-rpms"], ["systemd", "219-73.el7_8.9.x86_64 from rhui-rhel-7-server-rhui-rpms"], ["lvm2", "7:2.02.186-7.el7_8.2.x86_64 from rhui-rhel-7-server-rhui-rpms"], ["bind-utils", "32:9.11.4-16.P2.el7_8.6.x86_64 from rhui-rhel-7-server-rhui-rpms"], ["microcode_ctl", "2:2.1-61.10.el7_8.x86_64 from rhui-rhel-7-server-rhui-rpms"], ["selinux-policy-targeted", "3.13.1-266.el7_8.1.noarch from rhui-rhel-7-server-rhui-rpms"]]}, "finished": 1, "msg": "Error: Package: openvswitch2.13-2.13.0-29.el7fdp.x86_64 (aos-v4-devel-install)\n           Requires: openvswitch-selinux-extra-policy\n",
<--snip-->

Expected results:
Scale up successfully.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Russell Teague 2020-09-08 19:57:26 UTC
The rhel fast datapath repo is now required.

Comment 2 Johnny Liu 2020-09-09 05:54:56 UTC
Confirmed, after added fast datapath repo, rhel scaleup get completed successfully.

Remove 'TestBlocker' keyword.

If "The rhel fast datapath repo is now required", I think this bug need to be moved to 'Document' to reflect it.

Comment 3 Abhinav Dahiya 2020-09-09 17:01:14 UTC
Please update the documentation to provide details on the new package required for RHEL7 workers. based on https://bugzilla.redhat.com/show_bug.cgi?id=1874324

Comment 4 Abhinav Dahiya 2020-09-09 17:02:08 UTC
Dan can you help Docs team to update the requirements for ansible in docs. Pinging you since you helped fix the original bug.

Comment 5 Kathryn Alexander 2020-11-09 14:57:01 UTC
This change should be included on https://github.com/openshift/openshift-docs/pull/27135

Comment 6 Johnny Liu 2020-11-10 04:01:20 UTC
lgtm.

Comment 7 Kathryn Alexander 2020-11-10 16:06:10 UTC
Thanks! I've merged this change and am waiting for it to go live.

Comment 9 Red Hat Bugzilla 2023-09-14 06:08:10 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days