Bug 187670 - dangling symlink
dangling symlink
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: valgrind (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 09:56 EDT by Florian La Roche
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 05:58:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2006-04-02 09:56:59 EDT
Description of problem:
Not sure if this is a problem or not:
valgrind has dangling symlink from /usr/lib64/valgrind/x86-linux to
/usr/lib/valgrind/x86-linux



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2006-04-03 05:58:57 EDT
/usr/lib/valgrind/x86-linux is provided by i386.rpm valgrind.
If people install both valgrind*.x86_64.rpm and valgrind*.i386.rpm, they are
because of the above symlink able to trace both 32-bit and 64-bit programs,
while if they install just valgrind*.x86_64.rpm, they can only trace 64-bit ones
(and have stale symlink, but I think that's not a big deal).

Note You need to log in before you can comment on or make changes to this bug.