Bug 1876743 - Should describe clear what to fill in Fstype if disk is block when create localvolume on web console
Summary: Should describe clear what to fill in Fstype if disk is block when create loc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Jan Safranek
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-08 06:18 UTC by Chao Yang
Modified: 2020-10-27 16:38 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:38:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift local-storage-operator pull 151 0 None closed Bug 1876743: Add note about fsType value 2020-10-01 07:47:26 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:38:41 UTC

Description Chao Yang 2020-09-08 06:18:25 UTC
Description of problem:
Should describe clear what to fill in Fstype if disk is block when create localvolume on web console

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-09-03-191144
local-storage-operator.4.6.0-202009041839.p0

How reproducible:
Always

Steps to Reproduce:
1.Deploy LSO
2.Click localvolume
3.Check Storage Class Device
4.For FsType, default value is ext4
5.If choose VolumeMode as Block, FsType should fill with blank.
But there is no description how to fill FsType value here 

Actual results:
Fstype is not clear for customer how to create block storage class devices.

Expected results:
Add description about Fstype value when choose VolumeMode as Block.

Additional info:

Comment 1 Neha Gupta 2020-09-08 07:13:26 UTC
This is auto generated form based on the x-descriptors. This needs to handled via the backend. 
Also, the volume mode field dropdown should be moved above the FsType field dropdown, as its value gets change based on the volume mode selection.

Moving this to LSO team.

Comment 3 Rohan CJ 2020-09-08 07:57:22 UTC
The FSType field should be omitted when using volumeMode: Block

Comment 4 Michael Adam 2020-09-10 11:20:59 UTC
console RFE.

Should probably move to OCP, as it is an LSO piece.
But moving to OCS->management console first, for further triaging.

Comment 5 Neha Gupta 2020-09-14 06:34:53 UTC
This needs to fixed from the backend as the form are generated by the descriptors.

Comment 6 Jan Safranek 2020-09-15 12:17:44 UTC
We can't do cross-field validation, so I am updating the description to:

> File system type to create on empty volumes, such as "ext4" or "xfs". Used only when volumeMode is "Filesystem". Leave blank when volumeMode is "Block".

Comment 8 Chao Yang 2020-09-22 07:17:20 UTC
File system type to create on empty volumes, such as "ext4" or "xfs". Used only when volumeMode is "Filesystem". Leave blank when volumeMode is "Block". 
Above sentence is added 4.6.0-0.nightly-2020-09-21-030155
Update bz status.

Comment 11 errata-xmlrpc 2020-10-27 16:38:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.