Bug 1876822 - Random EOF error when checking env stability during Sriov Tests
Summary: Random EOF error when checking env stability during Sriov Tests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: CNF Platform Validation
Version: 4.6
Hardware: All
OS: All
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Federico Paolinelli
QA Contact: Nikita
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-08 09:20 UTC by Marcin Mirecki
Modified: 2020-10-27 16:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:38:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift sriov-network-operator pull 328 0 None closed Bug 1876822: Workaround for unexpected EOF during node state lookup 2020-12-11 02:36:24 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:38:41 UTC

Description Marcin Mirecki 2020-09-08 09:20:15 UTC
A eof error occurs randomly during SriovNetworkNodeStates lookup.

The test is performing a lookup to verify if the test environment is stable. The check is done at one second intervals for a few minutes, so for each test it can be hundreds or even tens of lookup calls. Once every while the lookup results in an eof error. The issue occurs only from within the tests (trying to reproduce it from cmd line was not successful), and as such is difficult to debug. 

The following PR is a workaround for the issue:
https://github.com/openshift/sriov-network-operator/pull/328

Comment 4 Nikita 2020-09-23 12:30:02 UTC
Bug fixed.
Move to VERIFIED

Comment 6 errata-xmlrpc 2020-10-27 16:38:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.