Bug 1876825 - APIFloatingIPAddress is asked in openshift-install wizard but not listed in install-config
Summary: APIFloatingIPAddress is asked in openshift-install wizard but not listed in i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
: 1877150 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-08 09:29 UTC by Jatan Malde
Modified: 2020-10-27 16:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:38:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4147 0 None closed Bug 1876825: generate lbFloatingIP in OpenStack config 2021-01-12 13:23:17 UTC
Red Hat Knowledge Base (Solution) 5440601 0 None None None 2020-09-28 21:29:34 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:38:47 UTC

Description Jatan Malde 2020-09-08 09:29:35 UTC
Description of problem:

Using the feature candidate build to install OpenShift on OpenStack, the wizard does ask for APIfloatingIPaddress as you can see in the following output. 

(overcloud) [stack@undercloud-0 bugtest]$ ./openshift-install version
./openshift-install 4.6.0-fc.4
built from commit 878562e15ce6c31148b4cff758ea70e685e6b6e3
release image quay.io/openshift-release-dev/ocp-release@sha256:960ec73733150827076cbb5fa2c1f5aaa9a94bfbce1b4897e46432a56ac976c1
(overcloud) [stack@undercloud-0 bugtest]$ 

(overcloud) [stack@undercloud-0 bugtest]$ ls
clouds.yaml  openshift-install
(overcloud) [stack@undercloud-0 bugtest]$ ./openshift-install create install-config
? SSH Public Key /home/stack/.ssh/id_rsa.pub
? Platform openstack
? Cloud openshiftkuryr
? ExternalNetwork public
? APIFloatingIPAddress 10.0.0.121
? FlavorName m1.shift
? Base Domain openstack.testing
? Cluster Name bugtest
? Pull Secret [? for help] *********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************INFO Install-Config created in: .                 
(overcloud) [stack@undercloud-0 bugtest]$ 


On checking the created install-config, I do not see the value as mentioned in the 4.6 documentation and the same is seen in the following snip.

(overcloud) [stack@undercloud-0 bugtest]$ cat install-config.yaml | grep -i openstack: -A7
  openstack:
    apiVIP: 10.0.0.5
    cloud: openshiftkuryr
    computeFlavor: m1.shift
    externalDNS: null
    externalNetwork: public
    ingressVIP: 10.0.0.7
publish: External
(overcloud) [stack@undercloud-0 bugtest]$ 

I will attach the install-config and the .openshift_install_state.json file on the bugzilla. 

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1. Pull openshift-install feature candidate build and attempt creating install-config for OpenShift on Openstack.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 5 Martin André 2020-09-11 09:30:13 UTC
*** Bug 1877150 has been marked as a duplicate of this bug. ***

Comment 6 David Sanz 2020-09-14 07:46:26 UTC
Verified on 4.6.0-0.nightly-2020-09-13-023938

$ oc adm release extract --tools registry.svc.ci.openshift.org/ocp/release:4.6.0-0.nightly-2020-09-13-023938
$ ./openshift-install version
./openshift-install v4.6.0
built from commit 0a4cc6c428c9d1aaf11d7f05002ab7637cdb872f
release image registry.svc.ci.openshift.org/ocp/release@sha256:a769f86c8e3679681c5c65f860a7167516befe11c5a6e441c9fe6070a4b70235
$ ./openshift-install create install-config
? SSH Public Key /home/morenod/.ssh/openshift-qe.pub
? Platform openstack
? Cloud openstack
? ExternalNetwork provider_net_shared_3
? APIFloatingIPAddress 10.0.109.211
? FlavorName ci.c1.xlarge
? Base Domain qe.com
? Cluster Name morenod
? Pull Secret [? for help] *************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
$ cat install-config.yaml 
apiVersion: v1
baseDomain: qe.com
compute:
- architecture: amd64
  hyperthreading: Enabled
  name: worker
  platform: {}
  replicas: 3
controlPlane:
  architecture: amd64
  hyperthreading: Enabled
  name: master
  platform: {}
  replicas: 3
metadata:
  creationTimestamp: null
  name: morenod
networking:
  clusterNetwork:
  - cidr: 10.128.0.0/14
    hostPrefix: 23
  machineNetwork:
  - cidr: 10.0.0.0/16
  networkType: OpenShiftSDN
  serviceNetwork:
  - 172.30.0.0/16
platform:
  openstack:
    apiVIP: 10.0.0.5
    cloud: openstack
    computeFlavor: ci.c1.xlarge
    externalDNS: null
    externalNetwork: provider_net_shared_3
    ingressVIP: 10.0.0.7
    lbFloatingIP: 10.0.109.211

Comment 8 errata-xmlrpc 2020-10-27 16:38:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.