Bug 187687 - GCC fails to rebuild itself for FC5 update kernel
GCC fails to rebuild itself for FC5 update kernel
Status: CLOSED DUPLICATE of bug 187853
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 13:18 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 08:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-04-02 13:18:47 EDT
Description of problem:
The command "rpmbuild --rebuild gcc-4.1.0-4.src.rpm" fails during the
install stage. 

Version-Release number of selected component (if applicable):
gcc-4.1.0-4

How reproducible:
Always

Steps to Reproduce:
1. Execute "rpmbuild --rebuild gcc-4.1.0-4.src.rpm".
  
Actual results:
Configure stage aborts with the following output:

"configure: error:
The following requested languages could not be built: ada
Recognised languages are: c,ada,c++,fortran,java,objc,obj-c++,treelang"

Expected results:
The package should have compiled cleanly.

Additional info:
This worked up to FC5 final. I got aware of the issue when I wanted to
update the package to gcc-4.2.0-20060401. Here, compilation aborts but
as pointed out above also already for the current offical rawhide SRPM.
Package "gcc-gnat-4.1.0-4" *is* installed.
Comment 1 Joachim Frieben 2006-04-02 13:20:44 EDT
Sorry, in "Description of problem:", I obviously meant " .. during the
configure stage."
Comment 2 Jakub Jelinek 2006-04-03 05:55:55 EDT
Works for me just fine.
Comment 3 Joachim Frieben 2006-04-03 08:01:21 EDT
Your system is really, really an FC6/rawhide one, I mean, you do not
compile "gcc-4.1.0-4.src.rpm" (FC6/rawhide package) on FC5 or other?
Comment 4 Jakub Jelinek 2006-04-03 09:52:36 EDT
Yes, it was a rawhide system, with *4.1.0-4* installed.
Comment 5 Joachim Frieben 2006-04-04 16:40:50 EDT
Well, some progress on the GCC front:

I reverted my system to FC5 from scratch. All volumes formatted, no
additional or customized dot files, one plain FC5 test user account.
My default shell is "csh" but "bash" makes no difference. My local
".rpmmacros" file reads:

  %_usrsrc                /home/test/build
  %_tmppath               /home/test/build/var/tmp

and the corresponding directory tree has been created in test's home
directory in order to avoid building the package as "root".

Result after installing FC5 w/o any updates:

"checking for gnatbind... gnatbind
 checking whether compiler driver understands Ada... yes"

After fully updating the system as of 04/04/06 and booting the system
again, the Ada driver stops working (!):

"checking for gnatbind... gnatbind
 checking whether compiler driver understands Ada... no"

In the first case, the system boots "kernel-2.6.15-1.2054_FC5", in the
second case "kernel-2.6.16-1.2080_FC5". After rebooting the updated
system again and booting "kernel-2.6.15-1.2054_FC5", case #1 occurs,
thus no error message. This is no delayed April's fool day hoax!
Rebooting the system several times confirms that for the original
FC5 kernel, the configure script passes successfully when checking
Ada support, and that for the update kernel the script fails.
Any clues?
Comment 6 Joachim Frieben 2006-04-04 16:43:29 EDT
The SRPM that failed to compile now of course is "gcc-4.1.0-3.src.rpm".
Comment 7 Jakub Jelinek 2006-04-05 08:53:28 EDT

*** This bug has been marked as a duplicate of 187853 ***
Comment 8 Joachim Frieben 2006-04-05 10:26:22 EDT
Isn't DUPLICATE marking handled according to the chronological order
of the involved bug reports? Just wondering .. . This somehow always
suggests that you hadn't checked the existing bug reports prior to
filing your own (duplicate) one.

Note You need to log in before you can comment on or make changes to this bug.