Bug 187689 - X11R7 directory layout breaks compatibility with older commercial apps
X11R7 directory layout breaks compatibility with older commercial apps
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 13:36 EDT by James
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 20:25:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2006-04-02 13:36:46 EDT
Description of problem:
Some older commercial applications (e.g. Mathematica 5) play up because of the
new directory layouts in libX11.

Version-Release number of selected component (if applicable):
libX11-1.0.0-3

How reproducible:
Always
  
Actual results:
Application will complain about missing locale, keysym data, etc.

Expected results:
Application behaves!

Additional info:
These applications expect data in /usr/X11R6/lib/X11 (take a look at the FC4
packages, for instance). I've resolved this for Mathematica 5 by creating the
following symlinks:

    /usr/X11R6/lib/X11 -> /usr/lib/X11
    /usr/lib/X11/{bindings, fonts, locale, XErrorDB, xkb, XKeysymDB}
                       -> (namesakes found in /usr/share/X11/)
Comment 1 Mike A. Harris 2006-04-03 21:33:28 EDT
Is Mathematica dynamically or statically linked to X libraries?  Please
provide the output of "ldd" on the binaries.

TIA
Comment 2 James 2006-04-04 03:39:14 EDT
ldd
/usr/local/Wolfram/Mathematica/5.0/SystemFiles/FrontEnd/Binaries/Linux/Mathematica
        linux-gate.so.1 =>  (0x00456000)
        libm.so.6 => /lib/libm.so.6 (0x0059d000)
        libc.so.6 => /lib/libc.so.6 (0x00474000)
        /lib/ld-linux.so.2 (0x00457000)
Comment 3 Mike A. Harris 2006-06-05 20:25:33 EDT
The caveat of statically linking software, is that it is frozen in time
to work on the system(s) it was compiled and linked on.

This is a flaw in Mathematica which is incompatible with X11R7.  Hopefully
they will address this in their next software release.  Please contact your
software vendor directly and request that they support X11R7 in future
Mathematica releases.

Closing as "NOTABUG", as this is not a bug in X.

Note You need to log in before you can comment on or make changes to this bug.