Bug 187692 - Cannot Play DVD Videos with Totem
Cannot Play DVD Videos with Totem
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Monty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 14:12 EDT by jarki
Modified: 2013-10-20 18:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-11 10:27:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 330086 None None None Never

  None (edit)
Description jarki 2006-04-02 14:12:24 EDT
Description of problem:

Can't play DVD videos with Totem.


Version-Release number of selected component (if applicable):

Totem 1.4.0
Movie Player using GStreamer 0.10.4


How reproducible:


Steps to Reproduce:
1. Open Totem.
2. Insert the DVD in the DVD device.

  
Actual results:

Totem could not play 'file:///dev/hdc'.
Could not determine type of stream.
 

Expected results:

Sould work, because Totem is movie player.

Additional info:

If you first insert the DVD in the DVD device, then Totem open automatically and
you get error
"Totem was not able to play this disc.
No reason."
Comment 1 Marius Andreiana 2006-04-03 12:57:34 EDT
I get a different error, that no codec exists for the DVD.
Comment 2 jarki 2006-04-04 09:36:42 EDT
Yes, the error can change/vary, but anyway can't play DVD:-(
Comment 3 Andre Robatino 2006-04-10 02:43:01 EDT
  According to totem's help, it's supposed to be possible to add proprietary
codecs to allow totem to play DVDs, among other things.  However, in the actual
GUI this ability doesn't exist.  Hence, it makes no sense for Fedora to make
totem the default application for playing DVDs, when it not only can't do this
out of the box (understandable since Fedora can't include the codecs), but
doesn't even allow adding the codecs!
Comment 4 jarki 2006-04-10 12:32:54 EDT
Agree - what we do with an application which does not work as expected? - more
harm than advantage. This kind of applications which are unable to do it's work
should be removed.
And on the other hand, these kind of thinks (DVD's, media issues, photos (bug
186131)) are basic thinks for users, so we should expect that the OS is capable
more than word processing in these days.
Comment 5 John Thacker 2006-04-14 16:26:27 EDT
Actually, in the actual GUI the ability to add support does exist.  You can add
the additional gstreamer-plugins from either freshrpms.net or from rpm.livna.org
and it will work fine.  Installing gstreamer-plugins-ugly and gstreamer-ffmpeg
will certainly give you enough to read DVD Video just fine.  (It will not
suffice for certain other codecs, though.)
Comment 7 Andre Robatino 2006-04-15 00:18:49 EDT
  According to the Help in Fedora's Totem, there is supposed to be an option for
adding codecs under the General tab under Preferences.  I don't see it there, or
anywhere else in the Totem GUI.  (Are you using another version of totem, such
as totem-xine?)  I installed the gstreamer-plugins-ugly and gstreamer-ffmpeg
packages from Freshrpms and still no luck.  There is nothing dealing with this
question at either fedorafaq.org (still at FC4) or at fedoranews.org.  Could you
describe EXACTLY where the GUI option to add extra codecs is?
Comment 8 jarki 2006-04-15 14:05:31 EDT
I would also like to know how to add codecs - although I think there's no option
for it.
Comment 9 Andre Robatino 2006-05-04 13:57:21 EDT
  I reopened this as bug #187692, since there's no response on exactly how to
add codecs in Fedora's totem (as opposed to the non-Fedora totem-xine package).
Comment 10 Andre Robatino 2006-05-04 13:58:18 EDT
  Sorry, I meant to say bug #190720.
Comment 11 jarki 2006-05-06 06:26:00 EDT
Reopened because someone has closed the bug without a resolution.
Comment 12 Andre Robatino 2006-05-06 11:00:38 EDT
  After adding the gstreamer-plugins-ugly and gstreamer-ffmpeg packages from
Freshrpms, and looking at the gnome.org bug reports in bug #190720, I found that
it's sometimes possible to play a DVD track by entering "dvd://<track number>"
under "Open Location..." or by giving the location on the command line (as in
"totem dvd://1").  On a DVD with 6 tracks, it was able to play 3 of them
(MPlayer could play all of them).  So there is some _extremely_ limited support.
 But it makes no sense to have totem be the default DVD player in this state. 
There's also the issue of the fact that Totem's Help is wrong.
Comment 13 John Thacker 2006-05-11 10:27:32 EDT
"since there's no response on exactly how to
add codecs in Fedora's totem"

Sorry if you didn't understand me, but I was not referring to totem-xine 
at all, and those detailed instructions DO add codec support to Fedora's
totem, NOT totem-xine.  However, there's a deeper problem.

Adding the gstreamer-plugins-bad, gstreamer-plugins-ugly, gstreamer-ffmpeg,
and gstreamer-pitfdll packages from freshrpms.net or from livna that I
mentioned absolutely DOES add codecs and support for other types
to gstreamer, and hence to the gstreamer-based totem AUTOMATICALLY,
without any special interaction with totem.  It certainly adds enough
to play MPEG2.

The separate option for a different location to put windows codec files
was removed from totem, but the help text incorrectly continues to
refer to it.  The upstream maintainer said "everyone using totem-xine
just uses /usr/lib/win32, and gstreamer doesn't support it"-- while
gstreamer-pitfdll supports the windows codecs, there's no interaction to 
set the direction gstreamer-pitfdll looks in with totem.  If gstreamer 
supports the file, totem will have support automatically.

However, what I didn't realize at the time that I posted the original
comment is that upstream totem has turned off DVD support due to not
all the required gstreamer plugins being ported to gstreamer 0.10
yet.  This is an exception to totem automatically playing things with
gstreamer support; it checks for DVDs and refuses to play them regardless
of the installed plugins.  By installing gstreamer-plugins-ugly, gstreamer
gets support for MPEG2, basic DVD support from libdvdread, and now
subtitle support which was just ported over.  The menu support plugin
has not yet been ported however.

I asked them to turn back on basic support, but they're refusing
to until all the plugins, including the one that gives menu support,
are ported to gstreamer-0.10.

There are no other options for the default DVD player because the rest
of them require DVD support to be built in when compiling, and Fedora
cannot distribute the required packages because of licensing and 
patent concerns.  Totem, by relying on gstreamer, allows DVD support,
like support for other patent-protected codecs, to be distributed and
added later without the involvement of RedHat or the Fedora Project
directly.  Fedora cannot distribute xine or mplayer with DVD support,
and there's no way to distribute a xine or mplayer without DVD support
and add support later by simply installing a separate plugin package.

The help file no longer refers to that option as of about two weeks ago.
It'll be fixed in the next upstream totem release:
http://bugzilla.gnome.org/show_bug.cgi?id=335445

I hope this answers your questions better than my original comments.
Comment 14 John Thacker 2006-05-11 10:33:05 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=330086

Also see the above bug report.
Comment 15 Andre Robatino 2006-05-11 12:02:52 EDT
  Thank you for the detailed explanation.  I added all 4 gstreamer packages you
mentioned from Freshrpms, but on the same DVD I tried before, it still plays
only 3 out of 6 tracks.  Although it's possible that the Freshrpms versions
might be out of date.

Note You need to log in before you can comment on or make changes to this bug.