Bug 187695 - rpm2cpio linked against fewer libraries
rpm2cpio linked against fewer libraries
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 16:11 EDT by Ed Avis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 07:11:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2006-04-02 16:11:11 EDT
The rpm2cpio binary included in Fedora's rpm package is linked against openssl
and neon among other libraries.  But it doesn't really need them.  (eg if you
replace these libraries with dummy symlinks to some unrelated library, rpm2cpio
will work and extract the contents of a package.)

Because rpm2cpio is an important rescue tool in the event the normal rpm program
stops working, it should not be linked against extraneous libraries.  Can you
change the build process to not use -lopenssl, etc. when linking rpm2cpio?
Comment 1 Jeff Johnson 2006-04-04 07:11:50 EDT
Use /usr/lib/rpm/rpm2cpio.sh instead.
Comment 2 Ed Avis 2006-04-04 10:03:11 EDT
>Use /usr/lib/rpm/rpm2cpio.sh instead.

Cool, didn't know about that.

Shouldn't it be installed in bin instead of lib?
Comment 3 James Olin Oden 2006-04-04 10:24:24 EDT
There are a lot of binaries/executables that are installed in /usr/lib/rpm.  
Its been this way forever.  One could argue they are misplaced, but historicaly 
they have always been there, so its kind of moot point (or maybe it not).

Also, I have a perl implementation of the same thing if you would like it.  
Pretty, much its pure perl except for the cpio part (no libcpio out there that 
was usuable that I could find; and there is now Archieve::CPIO module for perl 
either).

Note You need to log in before you can comment on or make changes to this bug.