This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 18770 - non root running of rpm is overly unhelpful
non root running of rpm is overly unhelpful
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 00:50 EDT by Idcmp
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-10 00:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Idcmp 2000-10-10 00:50:06 EDT
A frequent mistake I make, and have seen many others make, is to run rpm as
a non root user when doing installs.  Previously the error message was a
unhelp "unable to open rpm database".  Now the error message is a long
discourse about the possible need to upgrade my rpm database.

It would be nice if RPM did a simple check to see if the user was not uid 0
and prior to giving database migration instructions simply suggested I
become root first.

I'm willing to provide a patch if this would accelerated getting this
feature implemented.
Comment 1 Jeff Johnson 2000-10-10 17:00:30 EDT
FWIW, the "long discourse" is all that prevents disaster when upgrading from
rpm-3.0.x to rpm-4.0.

If you want to attempt a patch, see dbiOpen() in lib/rpmdb.c. I'll be happy to
consider changes,
but, I warn you ahead of time, the change is much trickier than it looks. Please
reopen this
bug if you succeed with a patch. Meanwhile, since the "long discourse" is
necessary and
not otherwise harmful, I'm gonna close this report.

Note You need to log in before you can comment on or make changes to this bug.