Bug 187705 - Rhythmbox 0.9.3.1-3 crashes upon adding songs
Rhythmbox 0.9.3.1-3 crashes upon adding songs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Monty
:
Depends On: 189189
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 21:03 EDT by Stewart Adam
Modified: 2013-10-20 18:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhythmbox-0.9.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 11:23:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2006-04-02 21:03:46 EDT
Description of problem:
When adding songs, a segfault occurs:
-- My Terminal --
[user@DellLin ~]$ rhythmbox
(rhythmbox:5692): Rhythmbox-WARNING **: Unable to start mDNS browsing
[I add the folder, then]
Segmentation fault
-- End My Terminal --

Version-Release number of selected component (if applicable):
rhythmbox-0.9.3.1-3

How reproducible:
Sometimes... Sometimes it will add, other times add with an error about bad MIME
types on 3 files, others it will crash.

Steps to Reproduce:
1. Start Rhythmbox
2. File > Import Folder, choose a folder
3. It crashes
  
Actual results:
Rhythmbox crashes, segfault

Expected results:
Add songs to library

Additional info:
The folder I'm adding contains only MP3's itself, although subfolders contain
.ram (realplayer) files.
Comment 1 Alex Lancaster 2006-04-17 22:34:54 EDT
There's a good chance this is fixed upstream.  Rhythmbox added better support to
stop rhythmbox crashing if gstreamer choked on particular files.  Bug #189189 is
an upgrade request.
Comment 2 John Thacker 2006-04-25 16:23:53 EDT
Please retest this with 0.9.4-1.fc5.1 from updates.
Comment 3 Stewart Adam 2006-08-14 11:23:15 EDT
Sorry for taking so long to reply, I guess I didn't see the needinfo email
request...
Anyways, now it's fine in rhythmbox-0.9.5-2.
Comment 4 Alex Lancaster 2006-08-14 11:47:51 EDT
But rhythmbox-0.9.5-2 doesn't appear to be either updates or updates-testing for
FC-5.
Comment 5 Stewart Adam 2006-08-14 13:24:22 EDT
Oh, sorry - I forgot to mention I installed FC6T2.
Comment 6 Alex Lancaster 2006-08-14 13:31:13 EDT
(In reply to comment #5)
> Oh, sorry - I forgot to mention I installed FC6T2.

Well, then the bug shouldn't be closed, (since it was opened as a FC-5 bug)
unless it has gone away in the latest FC-5 update, which was
rhythmbox-0.9.4.1-1.fc5.1.

Note You need to log in before you can comment on or make changes to this bug.