Bug 1877142 - clang-11: error: clang frontend command failed due to signal
Summary: clang-11: error: clang frontend command failed due to signal
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: clang
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom Stellard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-08 22:14 UTC by Omair Majid
Modified: 2020-10-09 13:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-09 13:50:44 UTC
Type: Bug


Attachments (Terms of Use)
/tmp/backtrace-a587c8.c (1.34 MB, text/plain)
2020-09-08 22:15 UTC, Omair Majid
no flags Details
/tmp/backtrace-a587c8.sh (5.89 KB, text/plain)
2020-09-08 22:15 UTC, Omair Majid
no flags Details

Description Omair Majid 2020-09-08 22:14:11 UTC
I am trying to build .NET Core 3.1.106 on Fedora 33 and running into this clang error.

To reproduce this error:

1. git clone https://github.com/dotnet/runtime
2. cd runtime
3. VERBOSE=1 ./build.sh --subset clr

You might have to install the build dependencies. `dnf build-dep dotnet3.1` should take care of that.

  cd /home/omajid/runtime/artifacts/obj/coreclr/Linux.arm64.Debug/src/pal/src/libunwind/src && /usr/bin/clang -DBUILDENV_CHECKED=1 -DDEBUG -DDISABLE_CONTRACTS -DHAVE_CONFIG_H=1 -DHAVE___THREAD=0 -DHOST_64BIT -DHOST_ARM64 -DHOST_UNIX -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_STRING=\"\" -DTARGET_64BIT -DTARGET_ARM64 -DTARGET_LINUX -DTARGET_UNIX -DURTBLDENV_FRIENDLY=Checked -DUSE_STL -D_DBG -D_DEBUG -D_GNU_SOURCE -Dasm=__asm__ -I/home/omajid/runtime/artifacts/obj/coreclr/Linux.arm
64.Debug/src/pal/src/libunwind/src -I/home/omajid/runtime/src/coreclr/src/pal/src/libunwind/src -I/home/omajid/runtime/src/coreclr/src/pal/inc -I/home/omajid/runtime/src/coreclr/src/pal/src -I/home/omajid/runtime/src/coreclr/src/pal/../inc -I/home/omajid/runtime/src/coreclr/src/pal/src/libunwind/include -I/home/omajid/runtime/src/coreclr/src/pal/src/libunwind/include/tdep -I/home/omajid/runtime/artifacts/obj/coreclr/Linux.arm64.Debug/src/pal/src/libunwind/include -I/home/omajid/runtime/artifacts/obj/coreclr/Linux.arm64.Debug/src/pal/src/libunwind/include/tdep -g -fPIC -O0 -g -Wall -Wno-null-conversion -fno-omit-frame-pointer -fms-extensions -fwrapv -fstack-protector-strong -Werror -Wno-unused-variable -Wno-unused-value -Wno-unused-function -ferror-limit=4096 -Wno-unused-private-field -Wno-microsoft -Wno-tautological-compare -Wno-constant-logical-operand -Wno-pragma-pack -Wno-unknown-warning-option -Wno-incompatible-ms-struct -fsigned-char -fvisibility=hidden -fexceptions -Wno-format -Wno-format-security -Wno-header-guard -Wno-absolute-value -std=gnu11 -o CMakeFiles/libunwind.dir/mi/backtrace.c.o -c /home/omajid/runtime/src/coreclr/src/pal/src/libunwind/src/mi/backtrace.c 
  PLEASE submit a bug report to  and include the crash backtrace, preprocessed source, and associated run script.      
  Stack dump:                                                                                                                                                                                                                                 
  0.    Program arguments: /usr/bin/clang -DBUILDENV_CHECKED=1 -DDEBUG -DDISABLE_CONTRACTS -DHAVE_CONFIG_H=1 -DHAVE___THREAD=0 -DHOST_64BIT -DHOST_ARM64 -DHOST_UNIX -DPACKAGE_BUGREPORT="" -DPACKAGE_STRING="" -DTARGET_64BIT -DTARGET_ARM64 -DTARGET_LINUX -DTARGET_UNIX -DURTBLDENV_FRIENDLY=Checked -DUSE_STL -D_DBG -D_DEBUG -D_GNU_SOURCE -Dasm=__asm__ -I/home/omajid/runtime/artifacts/obj/coreclr/Linux.arm64.Debug/src/pal/src/libunwind/src -I/home/omajid/runtime/src/coreclr/src/pal/src/libunwind/src -I/home/omajid/runtime/src/coreclr/src/pal/inc -I/home/omajid/runtime/src/coreclr/src/pal/src -I/home/omajid/runtime/src/coreclr/src/pal/../inc -I/home/omajid/runtime/src/coreclr/src/pal/src/libunwind/include -I/home/omajid/runtime/src/coreclr/src/pal/src/libunwind/include/tdep -I/home/omajid/runtime/artifacts/obj/coreclr/Linux.arm64.Debug/src/pal/src/libunwind/include -I/home/omajid/runtime/artifacts/obj/coreclr/Linux.arm64.Debug/src/pal/src/libunwind/include/tdep -g -fPIC -O0 -g -Wall -Wno-null-conversion -fno-omit-frame-pointer -fms-extensions -fwrapv -fstack-protector-strong -Werror -Wno-unused-variable -Wno-unused-value -Wno-unused-function -ferror-limit=4096 -Wno-unused-private-field -Wno-microsoft -Wno-tautological-compare -Wno-constant-logical-operand -Wno-pragma-pack -Wno-unknown-warning-option -Wno-incompatible-ms-struct -fsigned-char -fvisibility=hidden -fexceptions -Wno-format -Wno-format-security -Wno-header-guard -Wno-absolute-value -std=gnu11 -o CMakeFiles/libunwind.dir/mi/backtrace.c.o -c /home/omajid/runtime/src/coreclr/src/pal/src/libunwind/src/mi/backtrace.c                                                                         
  1.    <eof> parser at end of file                                                                                    
  2.    Code generation                                                                                                                                                                                                                       
  3.    Running pass 'Function Pass Manager' on module '/home/omajid/runtime/src/coreclr/src/pal/src/libunwind/src/mi/backtrace.c'.                                                                                                           
  4.    Running pass 'IRTranslator' on function '@unw_backtrace'                                                                                                                                                                              
   #0 0x0000ffffa314da84 llvm::sys::PrintStackTrace(llvm::raw_ostream&) (/lib64/libLLVM-11.so+0xa3ea84)
   #1 0x0000ffffa314c080 llvm::sys::RunSignalHandlers() (/lib64/libLLVM-11.so+0xa3d080)                                
   #2 0x0000ffffa308d7d8 (/lib64/libLLVM-11.so+0x97e7d8)                                                               
   #3 0x0000ffffaa22b5e8 (linux-vdso.so.1+0x5e8)                                                                       
   #4 0x0000ffffa35e44d0 llvm::TargetRegisterInfo::getRegSizeInBits(llvm::Register, llvm::MachineRegisterInfo const&) const (/lib64/libLLVM-11.so+0xed54d0)                                                                                   
   #5 0x0000ffffa38f1a44 (/lib64/libLLVM-11.so+0x11e2a44)                                                                                                                                                                                     
   #6 0x0000ffffa38f3968 llvm::InlineAsmLowering::lowerInlineAsm(llvm::MachineIRBuilder&, llvm::CallBase const&, std::function<llvm::ArrayRef<llvm::Register> (llvm::Value const&)>) const (/lib64/libLLVM-11.so+0x11e4968)
   #7 0x0000ffffa38e0cec llvm::IRTranslator::translateInlineAsm(llvm::CallBase const&, llvm::MachineIRBuilder&) (/lib64/libLLVM-11.so+0x11d1cec)                           
   #8 0x0000ffffa38f10f4 llvm::IRTranslator::runOnMachineFunction(llvm::MachineFunction&) (/lib64/libLLVM-11.so+0x11e20f4)                                                                                                                    
   #9 0x0000ffffa342d79c (/lib64/libLLVM-11.so+0xd1e79c)                                                                                                                                                                                      
  #10 0x0000ffffa325fe7c llvm::FPPassManager::runOnFunction(llvm::Function&) (/lib64/libLLVM-11.so+0xb50e7c)                                                                                                                                  
  #11 0x0000ffffa3260334 llvm::FPPassManager::runOnModule(llvm::Module&) (/lib64/libLLVM-11.so+0xb51334)                                                                                                                                      
  #12 0x0000ffffa325ee30 llvm::legacy::PassManagerImpl::run(llvm::Module&) (/lib64/libLLVM-11.so+0xb4fe30)
  #13 0x0000ffffa8a29158 clang::EmitBackendOutput(clang::DiagnosticsEngine&, clang::HeaderSearchOptions const&, clang::CodeGenOptions const&, clang::TargetOptions const&, clang::LangOptions const&, llvm::DataLayout const&, llvm::Module*, 
clang::BackendAction, std::unique_ptr<llvm::raw_pwrite_stream, std::default_delete<llvm::raw_pwrite_stream> >) (/lib64/libclang-cpp.so.11+0x1361158)
clang::BackendAction, std::unique_ptr<llvm::raw_pwrite_stream, std::default_delete<llvm::raw_pwrite_stream> >) (/lib64/libclang-cpp.so.11+0x1361158)                                                                                          
  #14 0x0000ffffa8c7778c (/lib64/libclang-cpp.so.11+0x15af78c)                                                                                                                                                                                
  #15 0x0000ffffa7ec067c clang::ParseAST(clang::Sema&, bool, bool) (/lib64/libclang-cpp.so.11+0x7f867c)
  #16 0x0000ffffa925f75c clang::FrontendAction::Execute() (/lib64/libclang-cpp.so.11+0x1b9775c)                                                                                                                                               
  #17 0x0000ffffa9236d78 clang::CompilerInstance::ExecuteAction(clang::FrontendAction&) (/lib64/libclang-cpp.so.11+0x1b6ed78)                                                                                                                 
  #18 0x0000ffffa92be5b8 clang::ExecuteCompilerInvocation(clang::CompilerInstance*) (/lib64/libclang-cpp.so.11+0x1bf65b8)                                                                                                                     
  #19 0x0000aaaac92e2924 cc1_main(llvm::ArrayRef<char const*>, char const*, void*) (/usr/bin/clang+0x12924)
  #20 0x0000aaaac92e5404 (/usr/bin/clang+0x15404)                                                                      
  #21 0x0000ffffa8f9ef50 (/lib64/libclang-cpp.so.11+0x18d6f50)
  #22 0x0000ffffa308d8c0 llvm::CrashRecoveryContext::RunSafely(llvm::function_ref<void ()>) (/lib64/libLLVM-11.so+0x97e8c0)
  #23 0x0000ffffa8fb2514 clang::driver::CC1Command::Execute(llvm::ArrayRef<llvm::Optional<llvm::StringRef> >, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >*, bool*) const (/lib64/libclang-cpp.so.11+0x18ea514)
  #24 0x0000ffffa8fb84ec clang::driver::Compilation::ExecuteCommand(clang::driver::Command const&, clang::driver::Command const*&) const (/lib64/libclang-cpp.so.11+0x18f04ec)
  #25 0x0000ffffa8fb88cc clang::driver::Compilation::ExecuteJobs(clang::driver::JobList const&, llvm::SmallVectorImpl<std::pair<int, clang::driver::Command const*> >&) const (/lib64/libclang-cpp.so.11+0x18f08cc)
  #26 0x0000ffffa8fb9c70 clang::driver::Driver::ExecuteCompilation(clang::driver::Compilation&, llvm::SmallVectorImpl<std::pair<int, clang::driver::Command const*> >&) (/lib64/libclang-cpp.so.11+0x18f1c70)
  #27 0x0000aaaac92df338 main (/usr/bin/clang+0xf338)
  #28 0x0000ffffa2376944 __libc_start_main (/lib64/libc.so.6+0x24944)
  #29 0x0000aaaac92e01a4 _start (/usr/bin/clang+0x101a4)
  clang-11: error: clang frontend command failed due to signal (use -v to see invocation)
  clang version 11.0.0 (Fedora 11.0.0-0.2.rc1.fc33)
  Target: aarch64-unknown-linux-gnu
  Thread model: posix
  InstalledDir: /usr/bin
  clang-11: note: diagnostic msg: 
  ********************
   
  PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
  Preprocessed source(s) and associated run script(s) are located at:
  clang-11: note: diagnostic msg: /tmp/backtrace-a587c8.c
  clang-11: note: diagnostic msg: /tmp/backtrace-a587c8.sh
  clang-11: note: diagnostic msg: 
     
  ********************

Comment 1 Omair Majid 2020-09-08 22:15:11 UTC
Created attachment 1714188 [details]
/tmp/backtrace-a587c8.c

Comment 2 Omair Majid 2020-09-08 22:15:39 UTC
Created attachment 1714189 [details]
/tmp/backtrace-a587c8.sh

Comment 3 serge_sans_paille 2020-09-17 09:54:07 UTC
Can you try to reproduce with rc2? I failed to reproduce using the upstream branch

Comment 4 Omair Majid 2020-10-09 13:50:44 UTC
Thanks, I have not been able to reproduce this issue in rawhide anymore. I am closing this now.


Note You need to log in before you can comment on or make changes to this bug.