Bug 187727 - gnome keyboard applet broken
gnome keyboard applet broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 05:36 EDT by A. Folger
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 15:32:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Folger 2006-04-03 05:36:24 EDT
Description of problem:
The Gnome keyboard applet doesn't switch keyboards after logging in again

Version-Release number of selected component (if applicable):
gnome-applets-2.14.0-1
libxklavier-2.2-1

How reproducible:


Steps to Reproduce:
1. Install two or more keyboard layouts, in my case, Swiss German Sun deadkeys
and Israeli Lyx, using the keyboard layout gui.
2. Then right click on panel and sellect add application/applet. Finally, broswe
down to keyboard apllet and select it. A keyboard layout selector will appear on
the panel.
3. Click on the selector, and see, by typing into any program, that the
different layouts work.
4. Logout and login again. Click on the keyboard layout selection applet and
notice that nothing changes and you only type in one layout. In my case, even
the main layout was broken, with Swiss German being replaced by something which
might be regular German layout (de_DE) or something similar.
  
Actual results:
Layout is no longer switched after having logged out and logged in again.

Expected results:
Keyboard applet works normally and all selected layouts can be used.

Additional info:
Even switching with the key combination meant to switch groups (e.g. both alt
keys in my case) no longer works. However, I could go through the pain of
deinstalling the layouts and reinstalling them during each session, and then I
would be able to use the various layouts for the duration of the session.
However, this is a pain.
Comment 1 A. Folger 2006-04-03 05:52:27 EDT
I just tested the keyboard applet with all kinds of layouts and it is entirely
broken. It doesn't matter which or how many layouts are selected, the behavior
of the selector applet is not what is expected. It doesn't register changes in
the list of layouts (if suddenly I uninstall all layouts and replace them by a
Thai keyboard, for the sake of the argument, the old list would still show up
when right clicking on the selector applet, until a few changes later, when Thai
is no longer installed, but it mysteriously appears in the selector applet).

This is a serious problem for international users.
Comment 2 Jørgen Thomsen 2006-04-28 09:06:48 EDT
I am not able to change the keyboard to Danish. It always remains as the US
keyboard. This is only a problem in the gnome GUI, not in the linux console
which is OK. This is a serious problem for non-US users.
Comment 3 Jørgen Thomsen 2006-04-28 13:14:55 EDT
A workaround is manually changing the X keyboard in /etc/X11/xorg.conf
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "dk"
Comment 4 Lutz Behringer 2006-07-01 02:31:46 EDT
Acutally I have the same problem: I'm also using a Swiss German keyboard.

This problem seems to be related to this gnome bugzilla report:

http://bugzilla.gnome.org/show_bug.cgi?id=340011

I patched also manually my xorg.conf. 
Comment 5 Matthias Clasen 2006-08-03 21:32:57 EDT
Works correctly in fc6.
Comment 6 Lutz Behringer 2006-08-09 13:47:34 EDT
Actually it is nog completely working. On my test system (FC6test2) I use a
Swiss German keyboard with a P/S2 connector. I cannot get the dead keys working.

The installed keyboard under system-administration-keyboard is Swiss German
(latin 1). The installed keyboard under system-preferences-keyboard settings are:

Generic 105 key (intl) PC keyboard, Layout Switzerland German, Sun dead keys.

Actually the Swiss German keyboard with dead keys worked in FC4, but not in FC5,
neither does it work in FC6test2. 

This is a fresh installation without any updates.
Comment 7 Lutz Behringer 2006-08-09 13:53:44 EDT
I forgot to add the relevant lines from my xorg.conf:

# XFree86 4 configuration created by pyxf86config

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "ch"
        Option      "Xkbvariant" "de_nodeadkeys"

I guess the option "Xkbvariant" is wrongly set.

Comment 8 Ray Strode [halfline] 2007-08-20 14:16:03 EDT
Are you guys still hitting this issue?
Comment 9 A. Folger 2007-08-20 14:54:47 EDT
No, but then again, I haven't used Gnome very much since. I quickly reverted 
to KDE (for many reasons). However, I do vaguely recall the issue seeming 
resolved.
Comment 10 Ray Strode [halfline] 2007-08-20 15:32:06 EDT
Okay, I'm going to go ahead and close this one out then.  If the problem
remanifests itself, any of guys feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.