Bug 1877309 - toolbox deleted files from keybase kbfs
Summary: toolbox deleted files from keybase kbfs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: podman
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Qi Wang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-09 11:26 UTC by Aron Griffis
Modified: 2021-01-28 12:16 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-28 12:16:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Aron Griffis 2020-09-09 11:26:25 UTC
Description of problem:
I have a bunch of files in Keybase KBFS. This is a streaming FUSE filesystem that stores encrypted in the cloud. https://book.keybase.io/docs/files

I used toolbox enter, then cleaned up with toolbox reset. The reset operation took a long time... turns out it was because it was "cleaning up" all my files in Keybase.


Version-Release number of selected component (if applicable):
0.0.95


How reproducible:
It happened yesterday, I'm not anxious to try again


Steps to Reproduce:
1. Get set up with https://keybase.io/
2. Store some files in /keybase/ which is a redirector to your personal kbfs mount
    ✸ ls -l /keybase/
    private -> /run/user/10208/keybase/kbfs/private
    public -> /run/user/10208/keybase/kbfs/public
    team -> /run/user/10208/keybase/kbfs/team
3. Make a toolbox
4. toolbox reset


Actual results:
Cleaned out keybase


Expected results:
Cluttered keybase


Additional info:
You can recover keybase files, dir by dir, with commands such as
    keybase fs recover --reltime=1h /keybase/private/agriffis/\*

Comment 1 Debarshi Ray 2020-09-09 12:40:09 UTC
Are you saying that you lost the contents of /run/user/10208/keybase?

'toolbox reset' is nothing but a wrapper around 'podman system reset'. Unless you use Toolbox's --assumeyes or -y flag, it should prompt you before proceeding to deleting anything. Even if you choose to proceed, it's meant to only clean up Podman's state, not anything else.

I just tried 'podman system reset' on my machine with Podman 2.0.5, and as far as I can make out, it didn't delete anything that it shouldn't have.

So, if it touched /run/user/10208/keybase, then it would appear to be a Podman bug.

Comment 2 Debarshi Ray 2020-09-09 12:42:57 UTC
This does remind me of https://github.com/containers/podman/issues/4831 but I thought that it was fixed a while back.

What's the output of 'rpm -q podman'?

Anyway, reassigning, because this is just 'podman system reset'.

Comment 3 Aron Griffis 2020-09-09 17:04:33 UTC
Yeah, it does look like that bug

podman-2.0.6-1.fc32.x86_64

Comment 4 Daniel Walsh 2020-09-11 20:21:38 UTC
So you are saying that `podman system reset` is removing content from  /run/user/10208/keybase?

Comment 5 Aron Griffis 2020-09-15 12:07:37 UTC
Yes, that's what I'm saying. Though I haven't tried it again since the first time it cleaned out my keybase filesystem.

Comment 6 Daniel Walsh 2020-09-15 20:32:34 UTC
Qi could you verify this?

Comment 7 Qi Wang 2020-10-05 14:10:37 UTC
I failed to regenerate this issue. I was using Version:2.0.6.


Note You need to log in before you can comment on or make changes to this bug.