Bug 1877343 - mokutil needs to be updated to retrieve th secure boot key from the kernel
Summary: mokutil needs to be updated to retrieve th secure boot key from the kernel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: mokutil
Version: 8.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 8.0
Assignee: Javier Martinez Canillas
QA Contact: Erico Nunes
URL:
Whiteboard:
: 1866107 (view as bug list)
Depends On: 1868306
Blocks: 1900044 1907418
TreeView+ depends on / blocked
 
Reported: 2020-09-09 12:28 UTC by Dave Young
Modified: 2020-12-14 13:38 UTC (History)
42 users (show)

Fixed In Version: mokutil-0.3.0-10.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1868820
: 1900044 1907418 (view as bug list)
Environment:
Last Closed: 2020-11-04 02:18:40 UTC
Type: ---
Target Upstream Version:


Attachments (Terms of Use)
mokutil-0.3.0-10.el8.x86_64.rpm (43.90 KB, application/x-rpm)
2020-09-22 10:38 UTC, Javier Martinez Canillas
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 5295541 0 None None None 2020-09-23 06:52:02 UTC
Red Hat Product Errata RHBA-2020:4604 0 None None None 2020-11-04 02:18:44 UTC

Comment 7 Javier Martinez Canillas 2020-09-22 10:38:20 UTC
Created attachment 1715679 [details]
mokutil-0.3.0-10.el8.x86_64.rpm

Comment 8 Renaud Métrich 2020-09-22 11:31:42 UTC
I confirm the new mokutil works assuming a recent kernel (I used kernel-core-4.18.0-239.el8.x86_64 is installed).

- With kernel-core-4.18.0-239.el8.x86_64 but mokutil-0.3.0-9.el8.x86_64:

  # mokutil --list-enrolled
  MokListRT is empty
  #

- With kernel-core-4.18.0-239.el8.x86_64 and mokutil-0.3.0-10.el8.x86_64:

  # mokutil --list-enrolled
  [key 1]
  ...
  #

- With kernel-4.18.0-193.19.1.el8_2.x86_64 and mokutil-0.3.0-10.el8.x86_64:

  # mokutil --list-enrolled
  #

  --> no output at all

Comment 9 Javier Martinez Canillas 2020-09-23 06:52:03 UTC
*** Bug 1866107 has been marked as a duplicate of this bug. ***

Comment 10 Renaud Métrich 2020-09-23 12:55:35 UTC
Making the bz public

Comment 18 errata-xmlrpc 2020-11-04 02:18:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (mokutil bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4604


Note You need to log in before you can comment on or make changes to this bug.