Bug 1877408 - Clean up invalid operator/v1 (Operator)LogLevels for all operators and tighten validation
Summary: Clean up invalid operator/v1 (Operator)LogLevels for all operators and tighte...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: config-operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Venkata Siva Teja Areti
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1866791 1878007
TreeView+ depends on / blocked
 
Reported: 2020-09-09 14:59 UTC by Stefan Schimanski
Modified: 2020-10-27 16:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1866791
: 1878007 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:38:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-config-operator pull 151 0 None closed Bug 1877408: Add Controller to Normalize the Operator Log Level Values 2020-10-26 02:08:50 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:39:12 UTC

Comment 1 Stefan Schimanski 2020-09-09 15:04:22 UTC
Note: this is the same for operatorLogLevel and logLevel

Comment 6 Venkata Siva Teja Areti 2020-09-21 19:16:05 UTC
@xxia This is expected behavior as the default sync period to normalize the log level is 5 minutes. considering kube-apiserver roll out time, it could take longer for it to normalize.

Comment 7 Xingxing Xia 2020-09-22 06:32:47 UTC
OK, thanks.

Comment 10 errata-xmlrpc 2020-10-27 16:38:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.