Bug 187742 - base python package not configured for Tk
base python package not configured for Tk
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 08:30 EDT by Dan O'Donovan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-08 11:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan O'Donovan 2006-04-03 08:30:37 EDT
Description of problem:
base Python rpm doesn't appear to be configured to use tkinter

Version-Release number of selected component (if applicable):
python-2.4.2-3.2.1

How reproducible:
Everytime

Steps to Reproduce:
1. run > python /usr/lib/python2.4/lib-tk/Tkinter.py
  
Actual results:
Error-

Traceback (most recent call last):
  File "/usr/lib/python2.4/lib-tk/Tkinter.py", line 38, in ?
    import _tkinter # If this fails your Python may not be configured for Tk
ImportError: libTix8.4.so: cannot open shared object file: No such file or directory


Expected results:
Import library Tkinter without complaint

Additional info:
Sorry if this is a requested feature and not a bug, python tkinter support was
in previous FC releases.
Comment 1 Dan O'Donovan 2006-04-06 09:22:28 EDT
Alternative Steps to Reproduce:
1. Start python
2. >>> import Tkinter
Comment 2 Dan O'Donovan 2006-04-06 11:06:51 EDT
Quick Fix:

Python or Tkinter looks for libTix8.4.so which lives in /usr/lib/Tix8.4 and
isn't in the default library path. I added a dynamic link in /usr/lib from
libTix8.4.so to Tix8.4/libTix8.4.so ... is this bad? 

I'm sorry I don't quite know where to file this, or if it's a genuine bug. 

Many thanks, Dan

Note You need to log in before you can comment on or make changes to this bug.