Bug 18775 - Certain apps dont compile
Certain apps dont compile
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 02:11 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-10 02:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-10 02:11:27 EDT
Hrm, I have both Rh 6.2 and RH 7 installed on 2 machines @ home and I would
like to say that some apps dont compile at all. One of them being cheops
and other being xmps-avi plugin. Both apps compile without a problem on
RH6.2

here is the output from the make command from both

Cheops:
[pramod@c846562-a cheops-0.60pre5]$ gmake
gcc -g -O2 -Wall -DDEFAULT_PATH=\"/usr/local/share/cheops\"
-DLIB_PATH=\"/usr/local/lib/cheops\" -I/usr/include -DNEED_GNOMESUPPORT_H
-I/usr/lib/gnome-libs/include -I/usr/lib/glib/include -I/usr/X11R6/include
-DUSE_GNOME -I/usr/include/ucd-snmp -DSNMP -DHAS_GMODULE   -c -o domain.o
domain.c
domain.c: In function `PrintListInfo':
domain.c:204: warning: implicit declaration of function `_getshort'
domain.c:213: warning: implicit declaration of function `_getlong'
domain.c:365: `T_UINFO' undeclared (first use in this function)
domain.c:365: (Each undeclared identifier is reported only once
domain.c:365: for each function it appears in.)
domain.c:366: `T_UID' undeclared (first use in this function)
domain.c:367: `T_GID' undeclared (first use in this function)
gmake: *** [domain.o] Error 1
[pramod@c846562-a cheops-0.60pre5]$ 


and for xmps avi-plugin

[pramod@c846562-a xmps-avi-plugin-0.0.2]$ gmake
Making all in loader
gmake[1]: Entering directory
`/home/pramod/compile/xmps-avi-plugin-0.0.2/loader'
gcc -c ./stubs.s -o stubs.o
gmake[1]: Leaving directory
`/home/pramod/compile/xmps-avi-plugin-0.0.2/loader'
Making all in videocodec
gmake[1]: Entering directory
`/home/pramod/compile/xmps-avi-plugin-0.0.2/videocodec'
g++ -I../include -rdynamic -fPIC -g  -c VideoDecoder.cpp
In file included from VideoDecoder.cpp:10:
../include/videodecoder.h:105:4: warning: no newline at end of file
VideoDecoder.cpp:180:2: warning: #warning NOT SURE
In file included from VideoDecoder.cpp:11:
../include/videodecoder.h: In method `void my_BITMAPINFO::setBitFields 
()':
../include/videodecoder.h:56: `abs' undeclared (first use this 
function)
../include/videodecoder.h:56: (Each undeclared identifier is reported 
only once for each function it appears in.)
gmake[1]: *** [VideoDecoder.o] Error 1
gmake[1]: Leaving directory
`/home/pramod/compile/xmps-avi-plugin-0.0.2/videocodec'
gmake: *** [all-recursive] Error 1

Any ideas?
Comment 1 Jakub Jelinek 2000-10-10 10:02:29 EDT
In the first case you could grab cheops-0.60pre5-11 from powertools, the
fix is:
--- cheops-0.60pre5/domain.c.decl       Mon Jul  3 10:13:22 2000
+++ cheops-0.60pre5/domain.c    Mon Jul  3 10:14:04 2000
@@ -362,9 +362,15 @@
            case T_LOC:
            case T_MINFO:
            case T_RP:
+#ifdef T_UINFO
            case T_UINFO:
+#endif
+#ifdef T_UID
            case T_UID:
+#endif
+#ifdef T_GID
            case T_GID:
+#endif
            case T_WKS:
                cp += dlen;
                break;
(apply this by hand, since the tabs are messed up).
The issue is that those resource types were marked as unstandard and were
removed (both in glibc 2.2 and current bind).

The second case looks like missing #include <stdlib.h> in VideoDecoder.cpp.
Older g++ used the builtin abs() prototype but that was just hiding a bug
in the application.

Note You need to log in before you can comment on or make changes to this bug.