Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1877510 - [Barbican] HMAC and MKEK generation for Luna HSM does not use HA slot
Summary: [Barbican] HMAC and MKEK generation for Luna HSM does not use HA slot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 16.1 (Train)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: z4
: 16.1 (Train on RHEL 8.2)
Assignee: Douglas Mendizábal
QA Contact: Jeremy Agee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-09 18:34 UTC by Douglas Mendizábal
Modified: 2021-03-17 15:32 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-11.3.2-1.20201114031847.el8ost, openstack-barbican-9.0.1-1.20201113140827.el8ost, puppet-barbican-15.4.1-1.20201114014405.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-17 15:31:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 760154 0 None MERGED Use serial number or label for PKCS#11 tokens 2021-02-17 13:29:44 UTC
OpenStack gerrit 760631 0 None MERGED Use barbican.conf in barbican-manage 2021-02-17 13:29:44 UTC
OpenStack gerrit 760638 0 None MERGED Add p11_crypto_plugin token options 2021-02-17 13:29:44 UTC
OpenStack gerrit 765008 0 None MERGED Identify HSMs using labels instead of Slot ID 2021-02-17 13:29:44 UTC
Red Hat Product Errata RHBA-2021:0817 0 None None None 2021-03-17 15:32:27 UTC

Description Douglas Mendizábal 2020-09-09 18:34:40 UTC
Description of problem:

When deploying OSP with 2+ Luna Network HSMs the MKEK and HMAC for Barbican are generated using the first partition (Slot #0) instead of the High Availability partition.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Ade Lee 2020-10-23 19:12:09 UTC
Pushed to 16.1.4

Comment 19 errata-xmlrpc 2021-03-17 15:31:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 16.1.4 director bug fix advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0817


Note You need to log in before you can comment on or make changes to this bug.