Bug 187766 - No __cxa_get_exception_ptr symbol in libstdc++
No __cxa_get_exception_ptr symbol in libstdc++
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc4 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 10:48 EDT by Rafal Wijata
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 05:04:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafal Wijata 2006-04-03 10:48:28 EDT
Description of problem:
while linking application with g++4 (gcc402), the error appears, that there is
no symbol
__cxa_get_exception_ptr
It should be in libstdc++, but it's not.

Version-Release number of selected component (if applicable):
gcc-c++ 4.0.2

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Jelinek 2006-04-03 11:16:06 EDT
It is not included there because RHEL4 includes libstdc++ from GCC 3.4.5-RH,
rather than 4.0.x.
But, g++4 included in RHEL4 has been patched not to ever use that symbol,
see gcc4-c++-pr10606-revert.patch in src.rpm.
I don't see how you can get that error unless you are using your own GCC 4.0.x
build rather than the one included in RHEL4.
Comment 2 Rafal Wijata 2006-04-04 03:29:47 EDT
In fact I was using 4.0.2 from FC, but when I saw RH released 4.0.2 version, I
reinstalled whole development packages (gcc*, cpp, binutils, libtools, libgcc,
libstdc++ and some more). However the symbol is still in use.
It's little strange, but only one object requires this(unfortunatelly I can't
show it to You...).
Adding -lsupc++ to the linking phase helped, but it's not what I looked for.
Comment 3 Rafal Wijata 2006-04-04 04:12:23 EDT
Well, in fact I have to apologize. It appeard to be problem with ccache was not
cleared.
ccache -C was not enought, but rm -rf /tmp/ccache fixed the thing.
Sorry and thanx. MArk is as a NOTaBUG

Note You need to log in before you can comment on or make changes to this bug.