Bug 1877688 - File conflict between tripleo-validations and validations-common
Summary: File conflict between tripleo-validations and validations-common
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 16.1 (Train)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z2
: 16.1 (Train on RHEL 8.2)
Assignee: Gaël Chamoulaud
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 08:04 UTC by Cédric Jeanneret
Modified: 2020-11-12 15:39 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-validations-11.3.2-1.20200914170825.el8ost
Doc Type: Release Note
Doc Text:
This update safeguards against potential package content conflict after content was moved from `openstack-tripleo-validations` to another package.
Clone Of:
Environment:
Last Closed: 2020-10-28 15:39:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 713204 0 None MERGED Remove objects migrated to validations-common 2021-01-20 19:50:35 UTC
OpenStack gerrit 750945 0 None MERGED Fix lower-constraints errors 2021-01-20 19:50:35 UTC
OpenStack gerrit 754090 0 None MERGED Remove objects migrated to validations-common 2021-01-20 19:49:55 UTC
OpenStack gerrit 754091 0 None MERGED Remove callback plugin from tripleo-validation 2021-01-20 19:49:55 UTC
OpenStack gerrit 755005 0 None MERGED Remove objects migrated to validations-common 2021-01-20 19:49:55 UTC
OpenStack gerrit 755006 0 None MERGED Remove callback plugin from tripleo-validation 2021-01-20 19:49:55 UTC
Red Hat Product Errata RHEA-2020:4284 0 None None None 2020-10-28 15:39:57 UTC

Description Cédric Jeanneret 2020-09-10 08:04:06 UTC
Hello,

While moving validations around and converging their installation path, a last patch is needed in order to ensure we don't get any conflicts with package content:
https://review.opendev.org/713204 (currently on master only, it will need some backport)

It was first detected in Upstream promotion:
https://bugs.launchpad.net/tripleo/+bug/1895056

Therefore, I'm creating this BZ a bit in advance in order to track it downstream, and request the blocker+ flag.

Timeline:
- master patch should be ready to merge by today's EOD (most of the CI issues are under control)
- backports should be merged pretty fast as well, depending on upstream CI status
- downstream backport can be done in parallel if needed

Cheers,

C.

Comment 2 Gaël Chamoulaud 2020-09-24 12:50:05 UTC
The backport to ussuri and train have to be done before moving to POST.

Comment 9 David Rosenfeld 2020-10-12 14:36:39 UTC
Validations may be executed and file conflict no longer seen. Note: some non-blocking problems were seen during validator regression:

https://bugzilla.redhat.com/show_bug.cgi?id=1887437 - IndexError: list index out of range when using an empty validation group in "run" subcommand
https://bugzilla.redhat.com/show_bug.cgi?id=1887444 - Running "openstack tripleo validator" without any overcloud leads to an inventory error and crash

Comment 13 errata-xmlrpc 2020-10-28 15:39:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 16.1 bug fix and enhancement advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:4284


Note You need to log in before you can comment on or make changes to this bug.