Bug 1877729 - russian translit m17n and chinese libpinyin input not working in qt under GNOME3 (Wayland)
Summary: russian translit m17n and chinese libpinyin input not working in qt under GNO...
Keywords:
Status: CLOSED DUPLICATE of bug 1832086
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-qt
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 10:07 UTC by Jeroen Wouters
Modified: 2020-09-11 01:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-11 01:01:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Jeroen Wouters 2020-09-10 10:07:54 UTC
Description of problem:
When using the "Russian (translit (m17n))" or "Chinese (Intelligent Pinyin)" keyboard layouts in GNOME3, the text typed is shown in latin characters.


Version-Release number of selected component (if applicable):
ibus 1.5.22
ibus-qt 1.3.3
ibus-m17n 1.4.3
ibus-libpinyin 1.11.92

How reproducible:
Always

Steps to Reproduce:
1. Select either "Russian (translit (m17n))" or "Chinese (Intelligent Pinyin)" keyboard layouts in GNOME3 (other layouts not tested)
2.  open a Qt application (tested: kwrite, marble, scribus, texmacs and cmake-gui)
3. Select one of the two above layouts and start typing

Actual results:
latin characters are entered into the program

Expected results:
either Cyrillic or Chinese characters should be input

Additional info:
QT_IM_MODULE is set to "ibus"

The following is the output of "strace kwrite |& grep platforminput":

access("/usr/lib64/qt5/plugins/platforminputcontexts/.", F_OK) = 0
openat(AT_FDCWD, "/usr/lib64/qt5/plugins/platforminputcontexts", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = 4
lstat("/usr/lib64/qt5/plugins/platforminputcontexts", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/usr/lib64/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so", {st_mode=S_IFREG|0755, st_size=29416, ...}) = 0
openat(AT_FDCWD, "/usr/lib64/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so", O_RDONLY|O_CLOEXEC) = 4
lstat("/usr/lib64/qt5/plugins/platforminputcontexts", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/usr/lib64/qt5/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so", {st_mode=S_IFREG|0755, st_size=135192, ...}) = 0
openat(AT_FDCWD, "/usr/lib64/qt5/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so", O_RDONLY|O_CLOEXEC) = 4
access("/usr/bin/platforminputcontexts/.", F_OK) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib64/qt5/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so.avx2", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
access("/usr/lib64/qt5/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so.avx2", F_OK) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib64/qt5/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so", O_RDONLY|O_CLOEXEC) = 4
openat(AT_FDCWD, "/usr/lib64/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so.avx2", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
access("/usr/lib64/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so.avx2", F_OK) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib64/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so", O_RDONLY|O_CLOEXEC) = 4

Comment 1 Jeroen Wouters 2020-09-10 10:30:48 UTC
I just tested this in a GNOME3 Xorg session. This works as expected. Only Wayland seems to be affected.

Comment 2 fujiwara 2020-09-11 01:01:28 UTC
(In reply to Jeroen Wouters from comment #0)
> openat(AT_FDCWD,
> "/usr/lib64/qt5/plugins/platforminputcontexts/
> libibusplatforminputcontextplugin.so", O_RDONLY|O_CLOEXEC) = 4

It's not ibus-qt which is used for Qt4 but not Qt5.

*** This bug has been marked as a duplicate of bug 1832086 ***


Note You need to log in before you can comment on or make changes to this bug.