Bug 1877736 - React Warning shown on close of Delete Revision modal
Summary: React Warning shown on close of Delete Revision modal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Jaivardhan Kumar
QA Contact: Karthik Jeeyar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 10:34 UTC by Jaivardhan Kumar
Modified: 2020-10-27 16:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:39:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of error (661.05 KB, image/png)
2020-09-10 10:34 UTC, Jaivardhan Kumar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6583 0 None closed Bug 1877736: fixes warning shown on close of delete revision modal 2020-09-23 07:31:23 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:39:48 UTC

Description Jaivardhan Kumar 2020-09-10 10:34:48 UTC
Created attachment 1714409 [details]
Screenshot of error

Description of problem: Warning shown on close of Delete Revision modal


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Install Serverless operator/ create required CRs
2. Deploy an image as knative service, wait for revision to show up
3. Edit knative Service to add one more revision
4. GO to topology , right click on revision via context menu click on delete revision
4. Close the modal

Actual results: Can see warning on console

`Warning: Can't perform a React state update on an unmounted component. This is a no-op, but it indicates a memory leak in your application. To fix, cancel all subscriptions and asynchronous tasks in a useEffect cleanup function.`


Expected results: Shouldn't show any warning


Additional info:

Comment 2 Karthik Jeeyar 2020-09-23 08:06:21 UTC
Verified on
BUild : 4.6.0-0.nightly-2020-09-22-213802
Url : https://console-openshift-console.apps.jakumar-22091122.devcluster.openshift.com/topology/ns/test-ns/graph?selectId=4eebf10e-c1d7-413d-b0c2-2820a5054644
user : Kubeadmin

Comment 5 errata-xmlrpc 2020-10-27 16:39:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.