Bug 187782 - No suspend option from login screen
No suspend option from login screen
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 12:06 EDT by Phil
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 14:31:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil 2006-04-03 12:06:06 EDT
Description of problem:

Suspend and hibernate work fine for all users, but there should be a way to
suspend a laptop from the login screen so the computer can be put to sleep
without shutting down and then having to restart.

Suggest adding options for hibernate and suspend from the login screen so that
when the laptop lid is opened the next user gets a login prompt in the shortest
amount of time possible.

When the lid is simply closed from the login screen and then reopened, the
screen shows garbage from which there is no recovery and requires a reboot.  I
believe this is doing a "screen blank" operation.  So perhaps if there was just
a way to set what happens on a lid close at the login screen that would be fine too.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nigel Cunningham 2006-11-09 04:21:13 EST
Regarding the garbage on the screen component, you probably need to run a
utility like vbetool or 915resolution after resuming, to restore your chipset's
configuration.
Comment 2 Ray Strode [halfline] 2007-08-20 14:31:58 EDT
This is something we want, but probably aren't going to get to until after Fedora 8.

The idea is should be able to use network manager, power manager, and other
things all from the greeter.

Anyway, i'm trying to prune my open issues right now (because it's getting
rather unmanageable, so I'm going to close this DEFERRED).

Note it is on the radar for a future Fedora, though.

Note You need to log in before you can comment on or make changes to this bug.