Bug 1877854 - MCO is not able to add second interface when we add a new machineset in Openstack Openshift UPI model
Summary: MCO is not able to add second interface when we add a new machineset in Opens...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: weiwei jiang
QA Contact: weiwei jiang
URL:
Whiteboard:
: 1866874 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 15:28 UTC by Pierre Prinetti
Modified: 2020-10-27 16:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:39:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4093 0 None closed Bug 1877854: OpenStack: Support multiple subnets 2021-01-18 05:53:50 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:39:52 UTC

Description Pierre Prinetti 2020-09-10 15:28:31 UTC
Description of problem:
In Openshift on openstack 4.4 UPI model, we attach a second interface via ansible scripts. However, post install if we create a new machineset, MCO is not able to add second interface when we add a new machineset 


Version-Release number of selected component (if applicable):
./openshift-install 4.4.13
built from commit db69e0456f2f7d6b937a8e88fc1ee6be32bf61fd
release image quay.io/openshift-release-dev/ocp-release@sha256:1b15aef0cf352b49be0b22f273663719dfdc111737e58a9080595623e47d7dd8

How reproducible:
Everytime

Steps to Reproduce:
1.Install the cluster with nodes having two interface. Second interface created via ansible playbooks.
2.Create a new machineset, and apply it.
3.VM comes up , but have only single interface.

Actual results:
VM have single interface

Expected results:
Should have 2 interfaces

Comment 1 Pierre Prinetti 2020-09-10 15:32:55 UTC
*** Bug 1866874 has been marked as a duplicate of this bug. ***

Comment 7 weiwei jiang 2020-09-30 09:39:19 UTC
Retried with     4.6.0-0.nightly-2020-09-30-014415, and now it work well.

# openstack server list --name wj46uos930
+--------------------------------------+----------------------------------+--------+------------------------------------------------------------------------------------+----------------------------+-----------+
| ID                                   | Name                             | Status | Networks                                                                           | Image                      | Flavor    |
+--------------------------------------+----------------------------------+--------+------------------------------------------------------------------------------------+----------------------------+-----------+
| ac4c4397-c597-4cf1-b894-72b419941d9b | wj46uos930x-qf744-worker-0-h79q7 | ACTIVE | wj46uos930x-qf744-network=192.168.0.141; openshift-qe-jenkins-network=172.16.10.50 | rhcos-46.82.202009222340-0 | m1.xlarge |
| 796bd3f5-87b6-460b-a449-5053c742bb2d | wj46uos930x-qf744-worker-2       | ACTIVE | wj46uos930x-qf744-network=192.168.1.2                                              | rhcos-46.82.202009222340-0 | m1.large  |
| 3f0bb26f-915a-4eef-819e-46149af60937 | wj46uos930x-qf744-worker-1       | ACTIVE | wj46uos930x-qf744-network=192.168.3.209                                            | rhcos-46.82.202009222340-0 | m1.large  |
| 6ee56c0a-de9f-488c-8ddc-083de84bf3a0 | wj46uos930x-qf744-worker-0       | ACTIVE | wj46uos930x-qf744-network=192.168.3.179                                            | rhcos-46.82.202009222340-0 | m1.large  |
| 5d59f217-6a56-46fc-bda0-7bce9a3b4151 | wj46uos930x-qf744-master-2       | ACTIVE | wj46uos930x-qf744-network=192.168.2.50                                             | rhcos-46.82.202009222340-0 | m1.xlarge |
| 3e9c4f87-5898-40cc-b746-1192adb1cca9 | wj46uos930x-qf744-master-1       | ACTIVE | wj46uos930x-qf744-network=192.168.2.82                                             | rhcos-46.82.202009222340-0 | m1.xlarge |
| 04e20cc6-0844-4323-9305-dc94cf78cbb1 | wj46uos930x-qf744-master-0       | ACTIVE | wj46uos930x-qf744-network=192.168.2.151                                            | rhcos-46.82.202009222340-0 | m1.xlarge |
+--------------------------------------+----------------------------------+--------+------------------------------------------------------------------------------------+----------------------------+-----------+


Machineset content:
    spec:
      metadata: {}
      providerSpec:
        value:
          cloudName: openstack
          networks:
            - filter: {}
              subnets:
                - filter:
                    name: wj46uos930x-qf744-nodes
                    tags: openshiftClusterID=wj46uos930x-qf744
            - filter: {}
              subnets:
                - filter:
                    name: openshift-qe-jenkins-subnet
                    tags: openshift-qe=true
          userDataSecret:
            name: worker-user-data-managed
          cloudsSecret:
            name: openstack-cloud-credentials
            namespace: openshift-machine-api
          metadata:
            creationTimestamp: null
          serverMetadata:
            Name: wj46uos930x-qf744-worker
            openshiftClusterID: wj46uos930x-qf744
          securityGroups:
            - filter: {}
              name: wj46uos930x-qf744-worker
          trunk: true
          kind: OpenstackProviderSpec
          tags:
            - openshiftClusterID=wj46uos930x-qf744
          image: rhcos-46.82.202009222340-0
          apiVersion: openstackproviderconfig.openshift.io/v1alpha1
          flavor: m1.xlarge


$ oc get nodes -o wide
NAME                               STATUS   ROLES    AGE     VERSION           INTERNAL-IP     EXTERNAL-IP   OS-IMAGE                                                       KERNEL-VERSION                 CONTAINER-RUNTIME
wj46uos930x-qf744-master-0         Ready    master   34m     v1.19.0+6ef2098   192.168.2.151   <none>        Red Hat Enterprise Linux CoreOS 46.82.202009291940-0 (Ootpa)   4.18.0-193.23.1.el8_2.x86_64   cri-o://1.19.0-18.rhaos4.6.gitd802e19.el8
wj46uos930x-qf744-master-1         Ready    master   32m     v1.19.0+6ef2098   192.168.2.82    <none>        Red Hat Enterprise Linux CoreOS 46.82.202009291940-0 (Ootpa)   4.18.0-193.23.1.el8_2.x86_64   cri-o://1.19.0-18.rhaos4.6.gitd802e19.el8
wj46uos930x-qf744-master-2         Ready    master   30m     v1.19.0+6ef2098   192.168.2.50    <none>        Red Hat Enterprise Linux CoreOS 46.82.202009291940-0 (Ootpa)   4.18.0-193.23.1.el8_2.x86_64   cri-o://1.19.0-18.rhaos4.6.gitd802e19.el8
wj46uos930x-qf744-worker-0         Ready    worker   25m     v1.19.0+6ef2098   192.168.3.179   <none>        Red Hat Enterprise Linux CoreOS 46.82.202009291940-0 (Ootpa)   4.18.0-193.23.1.el8_2.x86_64   cri-o://1.19.0-18.rhaos4.6.gitd802e19.el8
wj46uos930x-qf744-worker-0-h79q7   Ready    worker   5m38s   v1.19.0+6ef2098   192.168.0.141   <none>        Red Hat Enterprise Linux CoreOS 46.82.202009291940-0 (Ootpa)   4.18.0-193.23.1.el8_2.x86_64   cri-o://1.19.0-18.rhaos4.6.gitd802e19.el8
wj46uos930x-qf744-worker-1         Ready    worker   25m     v1.19.0+6ef2098   192.168.3.209   <none>        Red Hat Enterprise Linux CoreOS 46.82.202009291940-0 (Ootpa)   4.18.0-193.23.1.el8_2.x86_64   cri-o://1.19.0-18.rhaos4.6.gitd802e19.el8
wj46uos930x-qf744-worker-2         Ready    worker   24m     v1.19.0+6ef2098   192.168.1.2     <none>        Red Hat Enterprise Linux CoreOS 46.82.202009291940-0 (Ootpa)   4.18.0-193.23.1.el8_2.x86_64   cri-o://1.19.0-18.rhaos4.6.gitd802e19.el8

Comment 14 errata-xmlrpc 2020-10-27 16:39:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.