Bug 1877858 - ConsoleNotification without spec.location does not appear
Summary: ConsoleNotification without spec.location does not appear
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Robb Hamilton
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 15:40 UTC by Robb Hamilton
Modified: 2020-10-27 16:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-09-10-054902 Cluster ID: 39238a3a-3e39-4049-85eb-5947fecfd0ee Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.83 Safari/537.36
Last Closed: 2020-10-27 16:39:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6590 0 None open Bug 1877858: always output ConsoleNotification if notification.spec.… 2020-09-10 18:52:20 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:39:52 UTC

Description Robb Hamilton 2020-09-10 15:40:47 UTC
Description of problem:  When creating a ConsoleNotification, spec.location is optional; however, if no spec.location is specified, the ConsoleNotification will not appear in the console.


Steps to Reproduce:
1.  Visit /k8s/cluster/console.openshift.io~v1~ConsoleNotification/~new
2.  Delete spec.location
3.  Click Create
4.  Note the ConsoleNotification does not appear in the console.

Actual results:  No ConsoleNotification appears.


Expected results:  The console should default the location for any ConsoleNotification without a spec.location.

Comment 1 Robb Hamilton 2020-09-11 14:12:35 UTC
PR in the merge queue; bug awaiting QE verification.

Comment 3 Yanping Zhang 2020-09-14 14:01:04 UTC
Checked on ocp 4.6 cluster with payload 4.6.0-0.nightly-2020-09-12-230035。
1.  Visit /k8s/cluster/console.openshift.io~v1~ConsoleNotification/~new
2.  Delete spec.location
3.  Click Create.
4. The created ConsoleNotification appears on the top of the console.
The bug is fixed.

Comment 6 errata-xmlrpc 2020-10-27 16:39:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.