Bug 1877861 - Chart from default repos are browsable in UI even if no HelmChartRepository instances exist in cluster
Summary: Chart from default repos are browsable in UI even if no HelmChartRepository i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 15:46 UTC by Predrag Knezevic
Modified: 2020-10-27 16:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:39:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6588 0 None closed Bug 1877861: fix: return empty Helm repo index file when no HelmChartRepository instances are available in cluster 2020-11-12 13:07:25 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:39:52 UTC

Description Predrag Knezevic 2020-09-10 15:46:35 UTC
Description of problem:

In a cluster containing no HelmChartRepository instances, an user can still browse charts from the default repo (https://redhat-developer.github.io/redhat-helm-charts)


How reproducible:

1. remove all HelmChartRepository instances from the cluster
2. open up UI, go to Developer -> Add -> Helm Charts
3.

Actual results:

Chart tiles are displayed

Expected results:

No chart tiles

Comment 2 Rohit Rai 2020-09-23 14:55:05 UTC
Verified on 4.6.0-0.nightly-2020-09-22-130743

Comment 5 errata-xmlrpc 2020-10-27 16:39:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.