Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1877862 - UPI: condition on templates existence does not work and avoid get_url check
Summary: UPI: condition on templates existence does not work and avoid get_url check
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: OCP on RHV Team
QA Contact: Jan Zmeskal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 15:57 UTC by Roberto Ciatti
Modified: 2020-10-27 16:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:39:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4157 0 None closed Bug 1877862: oVirt UPI - Fix templates check and optimize image check 2020-10-20 11:11:59 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:39:52 UTC

Description Roberto Ciatti 2020-09-10 15:57:29 UTC
Description of problem:

When we check whether to run ovirt.image-tempalte role in create-templates-and-vms.yml, we use this condition: 

https://github.com/openshift/installer/blob/3883bef22659ec4fd636f675021ed3f98ed62804/upi/ovirt/create-templates-and-vms.yml#L67

However, this never resolves to true due to the fact that the templates list is actually a list of list


How reproducible:
Always

Steps to Reproduce:
1. launch the ansible-playbook -i inventory.yml create-templates-and-vms.yml
2. check that it downloads and uncompress the qcow2 image, creates templates and vms 
3. launch again the ansible-playbook -i inventory.yml create-templates-and-vms.yml


Actual results:
- check the remote image url (standard behaviour of ansible get_url)\
- re-create templates despite they already exists

Expected results:
skips both the download and the uncompress of the image (without reaching the remote image url) and skips also the templates creation

Comment 2 Sandro Bonazzola 2020-09-14 09:29:59 UTC
Handled only last week, needs QA, will be handled in upcoming sprint

Comment 3 Jan Zmeskal 2020-09-22 11:07:04 UTC
Verified by reviewing the associated PR.

Comment 7 errata-xmlrpc 2020-10-27 16:39:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.