Bug 1877909 - Cluster Logging instance says unsupported for NodeSelectors for all the logging components
Summary: Cluster Logging instance says unsupported for NodeSelectors for all the loggi...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.7.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks: 1904176
TreeView+ depends on / blocked
 
Reported: 2020-09-10 18:02 UTC by Anshul Verma
Modified: 2020-12-03 19:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1904176 (view as bug list)
Environment:
Last Closed: 2020-09-16 15:30:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Added a screenshot for the same. (112.91 KB, image/png)
2020-09-10 18:06 UTC, Anshul Verma
no flags Details
NodeSelectors in 4.6 (74.36 KB, image/png)
2020-09-16 15:29 UTC, Periklis Tsirakidis
no flags Details

Description Anshul Verma 2020-09-10 18:02:52 UTC
Description of problem:
When viewing the instance of ClusterLogging, the value of Node Selector for all the Logging component like `Kibana Node Selector`, `ElasticSearch Node Selector` etc. is shown `Unsupported`, it should be rather `None` if no NodeSelector is configured of the NodeSelector which is configured.

Version-Release number of selected component (if applicable):
OpenShift 4.5

Comment 1 Anshul Verma 2020-09-10 18:06:47 UTC
Created attachment 1714463 [details]
Added a screenshot for the same.

Comment 3 Jeff Cantrill 2020-09-11 19:32:41 UTC
Moving to low as setting nodeselectors is possible on all logging components

Comment 4 Armin Kunaschik 2020-09-14 16:06:16 UTC
@Jeff: It's not about the possibility to set a node selector, but about the incorrect display when one is configured!

Comment 5 Periklis Tsirakidis 2020-09-16 15:28:45 UTC
@Armin
This is fixed in 4.6, as we moved to properly generated CRDs addressed by [1]. I will close this issue as not a bug.

[1] https://github.com/openshift/cluster-logging-operator/pull/594

Comment 6 Periklis Tsirakidis 2020-09-16 15:29:19 UTC
Created attachment 1715101 [details]
NodeSelectors in 4.6

Comment 7 Periklis Tsirakidis 2020-09-16 15:30:43 UTC
And to catch the question upfront, we cannot backport the PR to 4.5.z


Note You need to log in before you can comment on or make changes to this bug.