Bug 1877943 - 4.6 apiserver/etcd performance analysis with late switch to Golang 1.15
Summary: 4.6 apiserver/etcd performance analysis with late switch to Golang 1.15
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Abu Kashem
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 20:19 UTC by Abu Kashem
Modified: 2020-10-27 16:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:39:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:39:52 UTC

Description Abu Kashem 2020-09-10 20:19:53 UTC
OpenShift 4.6 is migrating to (a default) of golang 1.15. Does this have any performance implications?

We want to understand if golang 1.15 introduces any performance regression. We can do the following:
- a simple test (maybe as simple as configmap create/update/get/delete), no pods churning so it does not need additional worker nodes.
- setup a cluster with latest 4.5 rc, run the test and establish a baseline.
- run the same test on 4.6 cluster, compare etcd/apiserver performance. check if there is any regression.

We can use the following test - https://github.com/tkashem/graceful/blob/master/cmd/loader/main.go

Comment 1 Abu Kashem 2020-09-25 17:33:47 UTC
Summary of the test results are captured here: https://hackmd.io/AG-8e7mgTv2Tgf-vyFMbag?edit. No noticeable performance regression detected at the specified apiserver load and test workload.

Comment 4 Ke Wang 2020-10-10 04:49:11 UTC
Per comment 1, we no need more performance tests for verification, just do below tests like description mentioned,
- a simple test (maybe as simple as configmap create/update/get/delete), no pods churning so it does not need additional worker nodes.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-10-09-224055   True        False         157m    Cluster version is 4.6.0-0.nightly-2020-10-09-224055

$ oc create configmap special-config --from-literal=special.how=very --from-literal=special.type=charm
configmap/special-config created

$ oc get configmaps special-config -o yaml
apiVersion: v1
data:
  special.how: very
  special.type: charm
kind: ConfigMap
metadata:
  creationTimestamp: "2020-10-10T04:40:46Z"
  managedFields:
  - apiVersion: v1
    fieldsType: FieldsV1
    fieldsV1:
      f:data:
        .: {}
        f:special.how: {}
        f:special.type: {}
    manager: oc
    operation: Update
    time: "2020-10-10T04:40:46Z"
  name: special-config
  namespace: default
  resourceVersion: "73990"
  selfLink: /api/v1/namespaces/default/configmaps/special-config
  uid: daa66863-bc85-4fae-8e45-f5d9ff86193b

Add one new field, 
$ oc edit configmaps special-config
configmap/special-config edited

$ oc get configmaps special-config -o yaml
apiVersion: v1
data:
  special.how: very
  special.type: charm
kind: ConfigMap
metadata:
  creationTimestamp: "2020-10-10T04:40:46Z"
  managedFields:
  - apiVersion: v1
    fieldsType: FieldsV1
    fieldsV1:
      f:data:
        .: {}
        f:special.how: {}
        f:special.type: {}
        f:special.what: {}
    manager: oc
    operation: Update
    time: "2020-10-10T04:40:46Z"
  name: special-config
  namespace: default
  resourceVersion: "74185"
  selfLink: /api/v1/namespaces/default/configmaps/special-config
  uid: daa66863-bc85-4fae-8e45-f5d9ff86193b
  
$ oc delete configmaps special-config
configmap "special-config" deleted

$ oc get configmaps special-config
Error from server (NotFound): configmaps "special-config" not found

Cluster works as expected, so move the bug VERIFIED.

Comment 6 errata-xmlrpc 2020-10-27 16:39:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.