Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1877944 - Missing info in side panel for Operator Backed Service
Summary: Missing info in side panel for Operator Backed Service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.0
Assignee: Jeff Phillips
QA Contact: Mohammed Saud
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 20:27 UTC by Jeff Phillips
Modified: 2020-10-27 16:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-08-02-091622 Cluster ID: 6f3ff509-b025-41f7-bb14-39ffbd691c34 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36
Last Closed: 2020-10-27 16:40:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6591 0 None closed Bug 1877944: Show all resources for selected operator in the topology side panel 2020-09-29 16:09:26 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:40:23 UTC

Description Jeff Phillips 2020-09-10 20:27:09 UTC
Description of problem:

Side panel of the Operator Backed Service is missing info in the Resources tab.
Based on original designs, Resource tab should have a "Managed by" line, including the associated CSV. It should also include all associated resources.


Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. Install an operator to the project
2. Navigate to the Developer perspective, topology
3. Select the grouping for the installed operator
4. Select the Resources tab in the side panel

Actual results:

A small list of resources is shown

Expected results:

A link the the CSV (managed by) should be shown.
The full list of resources should be shown. The list should contain the same items shown if you follow the heading link to the installed operator page and select the Resources tab there.


Additional info:

Comment 1 Mohammed Saud 2020-09-24 17:52:56 UTC
Verified on - 
Build: 4.6.0-0.nightly-2020-09-24-074159
Browser: Firefox 80
User: kubeadmin

Comment 4 errata-xmlrpc 2020-10-27 16:40:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.