Bug 1878015 - KCM cert-syncer panic when caches don't sync
Summary: KCM cert-syncer panic when caches don't sync
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Tomáš Nožička
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1879637
TreeView+ depends on / blocked
 
Reported: 2020-09-11 05:11 UTC by Tomáš Nožička
Modified: 2020-10-27 16:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1879637 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:40:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-controller-manager-operator pull 447 0 None closed Bug 1878015: Remove panic on cache sync 2021-01-22 03:55:21 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:40:23 UTC

Description Tomáš Nožička 2020-09-11 05:11:25 UTC
When caches fail to sync we shouldn't panic but only exit 1.

https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-origin-installer-e2e-gcp-4.6/1303842838693285888

Comment 2 zhou ying 2020-09-14 13:15:47 UTC
Confirmed with latest payload: 4.6.0-0.nightly-2020-09-12-230035, the issue has fixed:

1) Turn off kube-apiserver on node1;
2) Delete the kube-controller-manager-cert-syncer container of the same node;
3) Wait for 10 mins, check the kube-controller-manager-cert-syncer container again . 

Could see the container only exit with code 1 . no panic:

  kube-controller-manager-cert-syncer:
....
F0914 13:05:32.055616       1 base_controller.go:95] unable to sync caches for CertSyncController

      Exit Code:    1

Comment 5 errata-xmlrpc 2020-10-27 16:40:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.