Bug 1878037 - Dont provide non-admin user a link to upload a golden image since he does not have permissions to do that
Summary: Dont provide non-admin user a link to upload a golden image since he does not...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Gilad Lekner
QA Contact: Guohua Ouyang
URL:
Whiteboard: ux_issue
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-11 06:55 UTC by Tomas Jelinek
Modified: 2020-10-27 16:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:40:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6626 0 None closed Bug 1878037: Dont provide non-admin user a link to upload an image 2020-10-08 08:03:52 UTC
Github openshift console pull 6688 0 None closed Bug 1878037: Dont provide non-admin user a link to upload 2020-10-08 08:03:52 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:40:23 UTC

Description Tomas Jelinek 2020-09-11 06:55:57 UTC
Description of problem:
Even if you are not an admin user, you will be presented by an ability to upload a golden image. That is not correct, since all it will do is that it will lead to an error.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tomas Jelinek 2020-09-11 06:57:05 UTC
@Matt: what should happen in this case? Should the link not be available at all?

Comment 2 Matt 2020-09-11 12:51:17 UTC
We should probably just let them know they need to contact their admin to add the source. We shouldn't send them to a form they can't use.

Comment 3 Tomas Jelinek 2020-09-11 14:20:20 UTC
OK, but how should it actually look like? The message today is this:
"Operating system image not available. You can either <upload a new disk image> or define a boot source manually in the boot source dropdown".
how should the new look like? Something like:
"Operating system image not available. You can either talk to your administrator to define one or define a boot source manually in the boot source dropdown"
Would this work?

Comment 4 Matt 2020-09-11 17:26:29 UTC
Operating system source not available. Define a boot source manually below or request your administrator to define for the cluster.

I'm sure if that is worded correctly - but trying to teach them what "Source available" means.

Comment 6 Tomas Jelinek 2020-09-21 07:41:27 UTC
moving back to "assigned" since it does not work. I have a user which is not an admin and can not upload anything to the golden image namespace but the "upload a new disk image" button is present.

Comment 8 Guohua Ouyang 2020-09-22 03:19:19 UTC
> Define a boot source manually below or request your administrator to define a source for the cluster.

'For the cluster' sounds not good, is it for the operating system?

Comment 9 Tomas Jelinek 2020-09-22 08:56:33 UTC
(In reply to Guohua Ouyang from comment #8)
> > Define a boot source manually below or request your administrator to define a source for the cluster.
> 
> 'For the cluster' sounds not good, is it for the operating system?

The text change is tracked in https://bugzilla.redhat.com/show_bug.cgi?id=1880008
the proposed new text would be:
Default operating system image not available. Define a boot source manually below or request your administrator to define one for this operating system via the PVC upload form.

Moving this back to on_qa to verify if the behavior itself is correct

Comment 10 Guohua Ouyang 2020-09-22 09:27:32 UTC
Move the bug to verified as there is no "upload a new disk image" if it's non-admin user.

Comment 13 errata-xmlrpc 2020-10-27 16:40:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.