Bug 1878075 - OCP 4.6(support for multiple SCs) - UI should allow selecting an existing used RBD pool in Create StorageClass page
Summary: OCP 4.6(support for multiple SCs) - UI should allow selecting an existing use...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Kanika Murarka
QA Contact: Neha Berry
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-11 09:24 UTC by Neha Berry
Modified: 2020-10-27 16:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:40:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
Create SC page for RBD provisioner (129.03 KB, image/png)
2020-09-11 09:24 UTC, Neha Berry
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6684 0 None closed Bug 1878075: Remove filter for used pool 2021-01-12 21:33:55 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:40:24 UTC

Description Neha Berry 2020-09-11 09:24:58 UTC
Created attachment 1714535 [details]
Create SC page for RBD provisioner

Description of problem:
--------------------------------
With OCP 4.6 + OCS 4.6, we are supporting creation of custom Storageclasses on need basis.

In the Storage-> Storage Classes->Create Storage Class Page, If I select the provisioner as "openshift-storage.rbd.csi.ceph.com", the "Storage Pool" drop gets enabled.

it is seen that this dropdown does not list any Pool which is already used by other Storageclass. we get the option to create a new pool.

Ask : We should support multiple SC pointing to a single pool, hence the drop-down should list existing used RBD pool names too, along with an option to create a New Pool. Based on one's need, user can decide which path to take.
 

Version-Release number of selected component (if applicable):
---------------------------------------------------------------
OCP  = 4.6.0-0.nightly-2020-09-10-195619

How reproducible:
-------------------
Always

Steps to Reproduce:
1. Create an OCP 4.6 + OCS 4.5/4.6 cluster
2. Navigate to Storage-> Storage Classes->Create Storage Class
3. Select "openshift-storage.rbd.csi.ceph.com" under Provisioners box
4. Check the pools listed under the "Storage Pool" drop-down. it should list existing used Pools as well. 

Actual results:
--------------------
Only unused pools + Create New Pool option is available in drop-down

Expected results:
---------------------
Used pools + Unused pools + Create new pool options should all be available in drop-down


Additional info:

Comment 6 errata-xmlrpc 2020-10-27 16:40:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.