Bug 1878103 - Non-required Dialog dropdown field with default value of 0 shows "none" in order page
Summary: Non-required Dialog dropdown field with default value of 0 shows "none" in or...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.11.8
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.11.9
Assignee: Milan Zázrivec
QA Contact: Niyaz Akhtar Ansari
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-11 10:29 UTC by Niyaz Akhtar Ansari
Modified: 2020-11-05 22:05 UTC (History)
5 users (show)

Fixed In Version: 5.11.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-05 22:04:52 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:
simaishi: cfme-5.11.z+


Attachments (Terms of Use)
screenshot (70.46 KB, image/png)
2020-09-11 10:29 UTC, Niyaz Akhtar Ansari
no flags Details
dialog (2.87 KB, text/plain)
2020-09-11 10:30 UTC, Niyaz Akhtar Ansari
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4967 0 None None None 2020-11-05 22:05:03 UTC

Description Niyaz Akhtar Ansari 2020-09-11 10:29:47 UTC
Created attachment 1714546 [details]
screenshot

Description of problem:

Dialog dropdown field set to not required with a default value of 0. When ordering, the dropdown shows "none"

Version-Release number of selected component (if applicable):
Version 5.11.8.0.20200908214813_b3cc53d

How reproducible:
100%

Steps to Reproduce:
1. Create a service dialog and set dropdown field not required
2. Set default value zero
3. Go to the service order page
4. Value shows "None" instead of the default value set(which is zero)

Actual results:
Value is set to "none"

Expected results:
The value should be set to the default 


Additional info:

Comment 2 Niyaz Akhtar Ansari 2020-09-11 10:30:56 UTC
Created attachment 1714547 [details]
dialog

Comment 4 Milan Zázrivec 2020-09-11 10:34:23 UTC
Which CFME version had this working correctly?

Comment 5 Niyaz Akhtar Ansari 2020-09-11 10:46:21 UTC
Last working Version 5.11.7.3

Comment 6 Milan Zázrivec 2020-09-11 13:00:47 UTC
https://github.com/ManageIQ/ui-components/pull/451

Comment 7 CFME Bot 2020-09-16 11:41:33 UTC
New commit detected on ManageIQ/ui-components/master:

https://github.com/ManageIQ/ui-components/commit/60cd294e7aa4e63ffcbd5bf5e647b36c587f2c9e
commit 60cd294e7aa4e63ffcbd5bf5e647b36c587f2c9e
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Fri Sep 11 12:52:06 2020 +0000
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Fri Sep 11 12:52:06 2020 +0000

    Correctly set null as default value for null and empty strings

    https://bugzilla.redhat.com/show_bug.cgi?id=1878103

 src/dialog-user/services/dialogData.ts | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 8 CFME Bot 2020-09-30 18:16:25 UTC
New commit detected on ManageIQ/ui-components/ivanchuk:

https://github.com/ManageIQ/ui-components/commit/10a0003ef0edcefa7658eeee4b1c68cc339d3c91
commit 10a0003ef0edcefa7658eeee4b1c68cc339d3c91
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Wed Sep 16 11:40:47 2020 +0000
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Wed Sep 30 18:09:43 2020 +0000

    Merge pull request #451 from mzazrivec/correctly_set_default_values_for_null_and_empty_strings

    Correctly set null as default value for null and empty strings

    (cherry picked from commit c10011f0df9c51da0b8b953496dcfe1929f67478)

    https://bugzilla.redhat.com/show_bug.cgi?id=1878103

 src/dialog-user/services/dialogData.ts | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 15 errata-xmlrpc 2020-11-05 22:04:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (CloudForms 5.0.9 bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4967


Note You need to log in before you can comment on or make changes to this bug.