Bug 1878148 - Ingress Operator Fails to Delete DNSRecord
Summary: Ingress Operator Fails to Delete DNSRecord
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.z
Assignee: Stephen Greene
QA Contact: Hongan Li
URL:
Whiteboard:
: 1876919 (view as bug list)
Depends On: 1850813
Blocks: 1877928
TreeView+ depends on / blocked
 
Reported: 2020-09-11 13:24 UTC by Stephen Greene
Modified: 2020-09-21 17:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1850813
Environment:
Last Closed: 2020-09-21 17:42:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-ingress-operator pull 456 None closed [release-4.5] Bug 1878148: Backport: Delete Router Deployment Only Upon DNSRecord Deletion 2020-09-21 12:30:21 UTC
Red Hat Product Errata RHBA-2020:3719 None None None 2020-09-21 17:42:23 UTC

Comment 2 Hongan Li 2020-09-14 06:51:19 UTC
verified with 4.5.0-0.nightly-2020-09-12-040057 and issue has been fixed.

the default ingresscontroller can be deleted and no error "failed to delete dnsrecord" in the logs

Comment 4 Stephen Greene 2020-09-14 18:20:53 UTC
*** Bug 1876919 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2020-09-21 17:42:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719


Note You need to log in before you can comment on or make changes to this bug.