Bug 1878155 - Pormetheus Logs filled with a lot of no-op warnings
Summary: Pormetheus Logs filled with a lot of no-op warnings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Lili Cosic
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-11 13:48 UTC by Rick Rackow
Modified: 2020-10-27 16:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:40:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 927 0 None closed Bug 1878155: Remove deprecated baseImage 2020-09-28 08:40:51 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:40:24 UTC

Description Rick Rackow 2020-09-11 13:48:49 UTC
Description of problem:
We are seeing a lot of messsages in the prometheus logs like
```level=warn ts=2020-09-09T14:17:23.248971502Z caller=operator.go:1199 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.baseImage is deprecated, 'spec.image' field should be used instead"
level=warn ts=2020-09-09T14:17:23.248986852Z caller=operator.go:1209 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.thanos.baseImage is deprecated, 'spec.thanos.image' field should be used instead"```


Version-Release number of selected component (if applicable):
OpenShift dedicated (OCP 4.4.16)

How reproducible:
always

Steps to Reproduce:
1. oc logs -f $prometheus-pod
2.
3.

Actual results:
See logs above

Expected results:
We would expect this not to show up in the logs unless an actual issue aounr dthe images exists.


Additional info:
Since this is constantly reproducible, we can provide an OSD cluster and cluster admin access to that helps.

To get that, get in touch SRE-P

Comment 1 Lili Cosic 2020-09-11 13:56:45 UTC
Assigned to Damien, but he lacks bugzilla access so assigned to me temp.

Comment 5 Junqi Zhao 2020-09-25 03:22:12 UTC
reproduced on 4.4.0-0.nightly-2020-09-24-222539
# oc -n openshift-monitoring logs $(oc -n openshift-monitoring get po | grep prometheus-operator | awk '{print $1}') -c prometheus-operator | grep "level=warn" | head 
level=warn ts=2020-09-25T01:38:00.447550901Z caller=operator.go:513 component=alertmanageroperator msg="alertmanager key=openshift-monitoring/main, field spec.baseImage is deprecated, 'spec.image' field should be used instead"
level=warn ts=2020-09-25T01:38:00.480657482Z caller=operator.go:513 component=alertmanageroperator msg="alertmanager key=openshift-monitoring/main, field spec.baseImage is deprecated, 'spec.image' field should be used instead"
level=warn ts=2020-09-25T01:38:11.172024962Z caller=operator.go:1199 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.baseImage is deprecated, 'spec.image' field should be used instead"
level=warn ts=2020-09-25T01:38:11.172041355Z caller=operator.go:1209 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.thanos.baseImage is deprecated, 'spec.thanos.image' field should be used instead"
level=warn ts=2020-09-25T01:38:11.405429545Z caller=operator.go:1199 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.baseImage is deprecated, 'spec.image' field should be used instead"
level=warn ts=2020-09-25T01:38:11.405450409Z caller=operator.go:1209 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.thanos.baseImage is deprecated, 'spec.thanos.image' field should be used instead"
level=warn ts=2020-09-25T01:38:11.712997283Z caller=operator.go:1199 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.baseImage is deprecated, 'spec.image' field should be used instead"
level=warn ts=2020-09-25T01:38:11.713009248Z caller=operator.go:1209 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.thanos.baseImage is deprecated, 'spec.thanos.image' field should be used instead"
level=warn ts=2020-09-25T01:38:24.213948682Z caller=operator.go:1199 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.baseImage is deprecated, 'spec.image' field should be used instead"
level=warn ts=2020-09-25T01:38:24.2139768Z caller=operator.go:1209 component=prometheusoperator msg="prometheus key=openshift-monitoring/k8s, field spec.thanos.baseImage is deprecated, 'spec.thanos.image' field should be used instead"

Comment 6 Junqi Zhao 2020-09-25 03:46:25 UTC
tested with 4.6.0-0.nightly-2020-09-24-184015, no such issue
# oc -n openshift-monitoring logs $(oc -n openshift-monitoring get po | grep prometheus-operator | awk '{print $1}') -c prometheus-operator | grep "field should be used instead"
no result
# oc -n openshift-monitoring logs $(oc -n openshift-monitoring get po | grep prometheus-operator | awk '{print $1}') -c prometheus-operator | grep "is deprecated"
no result

Comment 9 errata-xmlrpc 2020-10-27 16:40:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.