Bug 1878354 - [rescue mode] "Pane is dead" error message with a tmpfs entry for /tmp in /etc/fstab
Summary: [rescue mode] "Pane is dead" error message with a tmpfs entry for /tmp in /et...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: python-blivet
Version: 8.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: 8.0
Assignee: Blivet Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-12 08:27 UTC by Christophe Besson
Modified: 2021-09-06 15:32 UTC (History)
4 users (show)

Fixed In Version: python3-blivet-3.2.2-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 03:22:25 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Christophe Besson 2020-09-12 08:27:30 UTC
Description of problem:
Booting on the DVD rescue mode fails with a tmpfs entry in /etc/fstab.
Need to backport the upstream patch.

Version-Release number of selected component (if applicable):
python3-blivet-3.1.0-21.el8_2

How reproducible:
100%

Steps to Reproduce:
1. Install a fresh OS
2. Add the entry below in /etc/fstab:
~~~
tmpfs  /tmp tmpfs rw,size=256m 0 0
~~~
3. Reboot on the DVD rescue mode

Actual results:
Got a python traceback and then "Pane is dead":
~~~
AttributeError" 'TmpFS' object has no attribute '_chrooted_mountpoint'
~~~

Additional info:
RHEL 8 delivers the version 3.1 of blivet. It has been fixed upstream in 3.1.7-1, in fedora 32 in 3.2.0-1.fc32.
BZ against fc32: https://bugzilla.redhat.com/show_bug.cgi?id=1784690
Upstream PR (one line patch): https://github.com/storaged-project/blivet/pull/822/commits/51373bd0a6378306dd0c269c3d5540751dad3be0

Comment 1 Jan Stodola 2020-09-14 08:38:14 UTC
python3-blivet-3.2.2-3.el8 is available in RHEL-8.3 Beta, which fixes this problem.

Comment 3 Jan Stodola 2020-09-14 08:53:37 UTC
Reproduced using RHEL-8.2 GA.
Verified on a RHEL-8.3 compose with python3-blivet-3.2.2-6.el8.

Moving to VERIFIED.

Comment 7 errata-xmlrpc 2020-11-04 03:22:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (python-blivet bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4728


Note You need to log in before you can comment on or make changes to this bug.