Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1878449 - cblas_zdotc_sub returns incorrect results on ppc64le
Summary: cblas_zdotc_sub returns incorrect results on ppc64le
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openblas
Version: rawhide
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-13 02:36 UTC by Elliott Sales de Andrade
Modified: 2020-09-28 00:14 UTC (History)
1 user (show)

Fixed In Version: openblas-0.3.10-6.fc31 openblas-0.3.10-6.fc32 openblas-0.3.10-6.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-27 01:05:03 UTC
Type: Bug


Attachments (Terms of Use)
Test program demonstrating the issue (1.04 KB, text/x-csrc)
2020-09-13 02:36 UTC, Elliott Sales de Andrade
no flags Details

Description Elliott Sales de Andrade 2020-09-13 02:36:26 UTC
Created attachment 1714660 [details]
Test program demonstrating the issue

I am trying to figure out why python-dask fails when built on ppc64le. I have traced the test failure back to NumPy and then to OpenBLAS in Fedora. I have not been successful in reproducing with upstream OpenBLAS, so possibly this has to do with some specific compiler flags used in the package build.

The attached file demonstrates the issue. On working systems (e.g., x86_64, any release), the two printed result should be complex conjugates. On ppc64le (>=32, *not* 31), one result is vastly different from the other.


Version-Release number of selected component (if applicable):
openblas-0.3.10-5.fc34.ppc64le
openblas-0.3.10-4.fc33.ppc64le
openblas-0.3.10-5.fc32.ppc64le

but NOT:
openblas-0.3.10-5.fc31.ppc64le


Steps to Reproduce:
$ mock -r $ROOT --install gcc openblas-devel
$ mock -r $ROOT --copyin test.c /
$ mock -r $ROOT --shell
# gcc -o test test.c -I /usr/include/openblas -lopenblas
# ./test


Actual results:
On Fedora 32, 33, Rawhide ppc64le:
Result: 1.862562916551286+1.737647909933064j
Result: 1.862562916551286-0.179897400206173j


Expected results:
On Fedora 31 ppc64le or x86_64 (any release):
Result: 1.862562916551287+1.917545310139237j
Result: 1.862562916551287-1.917545310139237j

Comment 1 Susi Lehtola 2020-09-15 13:44:35 UTC
Reported upstream at https://github.com/xianyi/OpenBLAS/issues/2837

Since there's a difference in the GCC version, this might also be a compiler bug.

Comment 2 Fedora Update System 2020-09-18 19:19:31 UTC
FEDORA-2020-24494f58a6 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-24494f58a6

Comment 3 Fedora Update System 2020-09-18 19:19:32 UTC
FEDORA-2020-717dfe4ee8 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-717dfe4ee8

Comment 4 Fedora Update System 2020-09-19 19:56:30 UTC
FEDORA-2020-717dfe4ee8 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-717dfe4ee8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-717dfe4ee8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-09-19 23:23:31 UTC
FEDORA-2020-24494f58a6 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-24494f58a6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-24494f58a6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-09-19 23:23:54 UTC
FEDORA-2020-c83d83368e has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-c83d83368e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c83d83368e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-09-27 01:05:03 UTC
FEDORA-2020-24494f58a6 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-09-27 01:57:20 UTC
FEDORA-2020-c83d83368e has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2020-09-28 00:14:42 UTC
FEDORA-2020-717dfe4ee8 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.