Bug 1878579 - cyclictest max latency is close to threshold 40us in rhel8.2.z kvm-rt testing with OSP16.1
Summary: cyclictest max latency is close to threshold 40us in rhel8.2.z kvm-rt testing...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: kernel-rt
Version: 8.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 8.0
Assignee: Nitesh Narayan Lal
QA Contact: Pei Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-14 03:05 UTC by Pei Zhang
Modified: 2021-01-20 02:18 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-05 12:36:08 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Pei Zhang 2020-09-14 03:05:40 UTC
Description of problem:

Doing 12h cyclictest test in rhel8.2.z with OpenStack 16.1, we got max latency 35us. This results are acceptable, but it's very close to the threshold established by us which is 40us. It's better to have a look about this issue.


Version-Release number of selected component (if applicable):
python3-openstackclient-4.0.0-0.20200310193636.aa64eb6.el8ost.noarch
tag: 16.1_20200813.1
qemu-kvm-4.2.0-29.module+el8.2.1+7297+a825794d.x86_64
tuned-2.13.0-6.el8.noarch
kernel-rt-4.18.0-193.19.1.rt13.70.el8_2.x86_64
rt-tests-1.5-18.el8.x86_64
libvirt-client-6.0.0-25.module+el8.2.1+7154+47ffd890.x86_64

How reproducible:
1/1

Steps to Reproduce:
1. Deploy OSP 16.1

2. In OSP 16.1, doing 12h cyclictest with 3 standard kvm-rt testing scenarios.

(1)Start 12h cyclictest in RT guest(s). 
# taskset -c 2,3,4,5,6,7,8,9 cyclictest -m -q -p95 -D 12h -h60 -t 8 -a 2,3,4,5,6,7,8,9 -i 200

(2)Meanwhile compiling kernel RT guest(s) housekeeping cores. 
 # while true; do cd /home/nfv-virt-rt-kvm/src/kernel-rt/linux-4.18.0-193.19.1.rt13.70.el8_2; make -j2>/dev/null; make clean>/dev/null; done

Actual results:
(1)Single VM with 1 rt vCPU:
# Min Latencies: 00007
# Avg Latencies: 00009
# Max Latencies: 00025

(2)Single VM with 8 rt vCPUs:
# Min Latencies: 00008 00013 00013 00013 00013 00013 00013 00013
# Avg Latencies: 00009 00013 00013 00013 00013 00013 00013 00013
# Max Latencies: 00024 00024 00024 00035 00024 00025 00023 00024

(3)Multiple VMs each with 1 rt vCPU:
- VM1
# Min Latencies: 00007
# Avg Latencies: 00009
# Max Latencies: 00022

- VM2
# Min Latencies: 00007
# Avg Latencies: 00009
# Max Latencies: 00021

- VM3
# Min Latencies: 00007
# Avg Latencies: 00009
# Max Latencies: 00020

- VM4
# Min Latencies: 00007
# Avg Latencies: 00009
# Max Latencies: 00021


Expected results:
We expect better latency number, not close to the threshold value.

Additional info:

Comment 11 Nitesh Narayan Lal 2020-10-22 20:47:21 UTC
Pei,

Once you test the latest 8.2.z kernel with OSP and get decent max latency values. 
Maybe we can close this bug?

I am hopeful that we will get better values because you are getting good results (24us) with a non-OSP setup.

Thanks

Comment 12 Pei Zhang 2020-11-05 12:35:36 UTC
(In reply to Nitesh Narayan Lal from comment #11)
> Pei,
> 
> Once you test the latest 8.2.z kernel with OSP and get decent max latency
> values. 
> Maybe we can close this bug?
> 
> I am hopeful that we will get better values because you are getting good
> results (24us) with a non-OSP setup.
> 
> Thanks

Nitesh,

The latest testing results look good. With osp 16.1, 12h oslat testing max latency is 9us,12h cyclictest max latency is 31us.

==12h oslat results==
(1)Single VM with 1 rt vCPU:
 Max Latency:    8 (us)

(2)Single VM with 8 rt vCPUs:
 Max Latency:    9 7 7 8 7 9 7 8 (us)

(3)Multiple VMs each with 1 rt vCPU:
- VM1
 Max Latency:    9 (us)

- VM2
 Max Latency:    9 (us)

- VM3
 Max Latency:    8 (us)

- VM4
 Max Latency:    9 (us)


==12h cyclictest results==
(1)Single VM with 1 rt vCPU:
# Min Latencies: 00007
# Avg Latencies: 00009
# Max Latencies: 00021


(2)Single VM with 8 rt vCPUs:
# Min Latencies: 00008 00013 00013 00013 00013 00012 00013 00013
# Avg Latencies: 00009 00013 00013 00013 00013 00013 00013 00013
# Max Latencies: 00025 00021 00024 00024 00021 00031 00024 00024

(3)Multiple VMs each with 1 rt vCPU:
- VM1
# Min Latencies: 00007
# Avg Latencies: 00009
# Max Latencies: 00020

- VM2
# Min Latencies: 00007
# Avg Latencies: 00009
# Max Latencies: 00021

- VM3
# Min Latencies: 00007
# Avg Latencies: 00009
# Max Latencies: 00021

- VM4
# Min Latencies: 00007
# Avg Latencies: 00011
# Max Latencies: 00024


==Versions==
python3-openstackclient-4.0.1-1.20200817092223.bff556c.el8ost.noarch
tag: 16.1_20201020.1
kernel-rt-4.18.0-193.30.1.rt13.79.el8_2.x86_64
qemu-kvm-4.2.0-29.module+el8.2.1+7990+27f1e480.4.x86_64
192.168.24.1:8787/rh-osbs/rhosp16-openstack-nova-libvirt:16.1_20201020.1
tuned-2.13.0-6.el8.noarch
rt-tests-1.5-18.el8.x86_64

Comment 13 Pei Zhang 2020-11-05 12:36:08 UTC
So close this bug.

Comment 14 Nitesh Narayan Lal 2020-11-05 14:02:49 UTC
Thanks, Pei.
As we discussed previously over email, I agree with your conclusion.
Thanks


Note You need to log in before you can comment on or make changes to this bug.