Bug 1878602 - Add support for stalld to NTO
Summary: Add support for stalld to NTO
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Tuning Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.6.0
Assignee: Jiří Mencák
QA Contact: Simon
URL:
Whiteboard:
: 1855447 (view as bug list)
Depends On:
Blocks: 1861094
TreeView+ depends on / blocked
 
Reported: 2020-09-14 06:21 UTC by Martin Sivák
Modified: 2020-10-27 16:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:40:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-node-tuning-operator pull 152 0 None closed Bug 1878602: Support for stall daemon. 2020-12-10 01:08:26 UTC
Github redhat-performance tuned pull 293 0 None closed Added plugin 'service' 2020-12-10 01:08:27 UTC
Red Hat Bugzilla 1855447 0 urgent CLOSED FIFO priority causes hung tasks 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1869991 0 unspecified CLOSED [RFE] Provide a plugin that allows a profile to request starting a service in a declarative fashion 2021-05-18 16:41:20 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:01 UTC

Description Martin Sivák 2020-09-14 06:21:13 UTC
Description of problem:

We found out that a special daemon needs to be started on a node to achieve really low latencies needed for Telco vRAN (See https://bugzilla.redhat.com/show_bug.cgi?id=1855447#c24 and later comments).

This daemon is only needed for real time nodes and so it is logical to enable it via NTO that is profile aware.


Due to customer requirements we request that as simple as possible stop gap solution is included into 4.6 even though we are past the feature freeze.

Upstream tuned was already enhanced with declarative service management plugin: https://github.com/redhat-performance/tuned/pull/293

Comment 3 Simon 2020-09-22 19:08:34 UTC
$ for pod in $(oc get pods | grep tuned | cut -d ' ' -f 1); do echo $pod; oc rsh $pod ls /usr/local/bin; done                                                                      
tuned-52hsg
stalld
tuned-6w8c8
stalld
tuned-f6h56
stalld
tuned-f7v56
stalld
tuned-fckwc
stalld
tuned-jnqpj
stalld
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-09-21-182309   True        False         3h43m   Cluster version is 4.6.0-0.nightly-2020-09-21-182309

Comment 5 Luiz Capitulino 2020-10-08 20:39:54 UTC
*** Bug 1855447 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2020-10-27 16:40:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.