Bug 187864 - gcc package ignores %_tmppath value and always uses /var/tmp
gcc package ignores %_tmppath value and always uses /var/tmp
Status: CLOSED DUPLICATE of bug 174594
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On: 187594
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 23:22 EDT by Eugene Kanter
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 05:41:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2006-04-03 23:22:50 EDT
+++ This bug was initially created as a clone of Bug #187594 +++

Description of problem:

BuildRoot value is hardcoded in spec to /var/tmp/gcc-root. It should be
something like %{_tmppath}/%{name}-%{version}-root.

-- Additional comment from jakub@redhat.com on 2006-04-03 07:18 EST --
It really doesn't matter, it is overridden almost always anyway.
There are many packages that have similar buildroot values.
All that matters is whether the BuildRoot tag is present or not.

-- Additional comment from ekanter@rcn.com on 2006-04-03 08:52 EST --
There probably is some other issue in gcc spec file. GCC was the only package
out of all RHELv4 updates which completely ignored

%_tmppath %(eval 'echo $HOME/tmp')

in ~/.rpmmacros and continued to place its files in /var/tmp/gcc-root

-- Additional comment from ekanter@rcn.com on 2006-04-03 23:18 EST --
Original submitter is not able to reopen the but so I am creating another one.
Comment 1 Jakub Jelinek 2006-04-04 05:41:38 EDT
I've changed this even in RHEL4's gcc34.spec, though I'd say changing it in
gcc41.spec for FC5/RHEL5+ was more than enough back in December.

*** This bug has been marked as a duplicate of 174594 ***

Note You need to log in before you can comment on or make changes to this bug.