Bug 1878653 - event source form create button enabled when form is invalid
Summary: event source form create button enabled when form is invalid
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-14 09:51 UTC by Jaivardhan Kumar
Modified: 2020-10-27 16:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:40:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6611 0 None closed Bug 1878653: fixes event source form create button enabled when form is invalid 2020-09-21 18:07:06 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:01 UTC

Description Jaivardhan Kumar 2020-09-14 09:51:08 UTC
Description of problem:
Clicking multiple times on the event source type in the event source form will toggle the create button enablement even when the form is invalid.

Prerequisites (if any, like setup, operators/versions):
install knative serverless operator

Steps to Reproduce
1. go to add => event sources
2. Select a type
3. Click the same type again

Actual results:
Create button becomes enabled. Clicking the same type again toggles the create button enablement between disabled and enabled.

Expected results:
Create button should remain disabled until form is valid.

Reproducibility (Always/Intermittent/Only Once):
always

Build Details:
4.6.0-0.nightly-2020-07-07-233934

Comment 1 Jaivardhan Kumar 2020-09-14 09:55:30 UTC
Jira for tracking https://issues.redhat.com/browse/ODC-4302

Comment 3 Debsmita Santra 2020-09-21 18:08:59 UTC
verified on build 4.6.0-0.nightly-2020-09-21-081745

Comment 6 errata-xmlrpc 2020-10-27 16:40:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.